Ask Your Question
0

problems with ROSARIA

asked 2011-11-09 20:54:04 -0500

arroyo gravatar image

I am trying to install ROSARIA package for use with a pioneer robot P3DX. I am trying with two methods.

1. $ sudo svn co https://amor-ros-pkg.googlecode.com/hg/

the response is

svn: The server sent unexpected return value (405 Method Not Allowed) OPTIONS for in response to the request «https://amor-ros-pkg.googlecode.com/hg»

2. $ sudo rosinstall /opt/ros//electric/ 'http://www.ros.org/wiki/ROSARIA/Tutorials/How%20to%20use%20ROSARIA?action=AttachFile&do=get&target=amor-ros-pkg.rosinstall'

the response is

RuntimeError: maximum recursion depth exceeded

I don't know how install ROSARIA package. Can you help me please??

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
1

answered 2011-11-10 10:53:38 -0500

karthik gravatar image

updated 2011-11-16 01:58:42 -0500

Hi, I faced similar issue. It is the version control issue. I went to the link https://amor-ros-pkg.googlecode.com/hg/">https://amor-ros-pkg.googlecode.com/hg/ and downloaded files and folders manually. And placed them in the same tree structure as given in the server and followed the rest of the process in the tutorial http://www.ros.org/wiki/ROSARIA/Tutorials/How%20to%20use%20ROSARIA. It worked for me. Let me know if you face any issues in the process. Hope this helps.

Thanks, Karthik


Edited on Nov 16

To move the robot you should have the teleop_base installed. You can check the other answer that posted. http://answers.ros.org/question/2928/require-help-using-rosaria#4674 Pls check the topics where the nodes are publishing using either

rostopic list

or

rxgraph

Thanks, Karthik

edit flag offensive delete link more
0

answered 2011-11-15 04:57:17 -0500

Puneeth gravatar image

Hi all, I am totally new to ROS, I know really little about it. I have a task of using ROSARIA to run my pioneer robot.

Initially I also had the problem of Installing the package, but I tried doing the 2nd method

$ sudo rosinstall /opt/ros//electric/ 'http://www.ros.org/wiki/ROSARIA/Tutorials/How%20to%20use%20ROSARIA?action=AttachFile&do=get&target=amor-ros-pkg.rosinstall'

I saw it got installed.

when I run rosmake ROSARIA I get the following error:

[ rosmake ] Packages requested are: ['ROSARIA']
[ rosmake ] Logging to directory/home/mycomp/.ros/rosmake/rosmake_output-20111115-194506 [ rosmake ] Expanded args ['ROSARIA'] to: []
[ rosmake ] WARNING: The following args could not be parsed as stacks or packages: ['ROSARIA'] [ rosmake ] ERROR: No arguments could be parsed into valid package or stack names.

then I noticed that in my folder I had a file ".hgignore" missing in the installed in directory, I tried to create but as it has no name I couldn't, I am not sure If i am doing the right thing and is that file needed ?? rest all the files were proper.

Need help in this regard.

edit flag offensive delete link more

Comments

Puneeth, you can post this as a new question.
karthik gravatar image karthik  ( 2011-11-15 13:03:39 -0500 )edit

try this. Put the cursor in stack directory and type this hg clone https://code.google.com/p/amor-ros-pkg/ after that try rosmake again.

arroyo gravatar image arroyo  ( 2012-02-27 22:25:29 -0500 )edit

Hi you must put the hg folder in your ROS stack , or in your secondary Ros_package_path . is it in correct path?

farshid616 gravatar image farshid616  ( 2012-03-05 02:25:42 -0500 )edit
0

answered 2011-11-14 01:11:09 -0500

arroyo gravatar image

I cloned the directories with

hg clone https://code.google.com/p/amor-ros-pkg/

Now, I have problems compiling the package.

{__________________________________________________________________ make wipe make[1]: it go to the directory <</opt>> rm –rf bluild/Aria-2.7.2 Aria rm –f *~installed rm –f build/ARIA-2.7.2.tgz make[1]: it leave the directory <</opt>> touch wiped touch: can't do 'touch’ by <<wiped>>: Permiss refused _____________________________________________________________________}

edit flag offensive delete link more

Comments

Change the permissions of the folder and compile the package again.
karthik gravatar image karthik  ( 2011-11-14 01:49:13 -0500 )edit
0

answered 2011-11-14 20:36:11 -0500

arroyo gravatar image

I have solved the problem. Now I connect with the robot, but I can't send orders. The robot don't move.

edit flag offensive delete link more

Comments

Firstly, its a good practice to edit your questions or give comments in this forum than posting answers every time.
karthik gravatar image karthik  ( 2011-11-14 22:19:39 -0500 )edit
Pls check the teleop_base node that comes with rosaria. It works and you can create your nodes based on this node.
karthik gravatar image karthik  ( 2011-11-14 22:20:34 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-11-09 20:54:04 -0500

Seen: 744 times

Last updated: Nov 16 '11