Ask Your Question
0

roslaunch ROSARIA problem

asked 2013-07-10 23:46:38 -0600

acp gravatar image

Dear all.

I can run:rosrun ROSARIA RosAria

But when I run the following in a launch file

<launch>

<node name="RosAria" pkg="ROSARIA" type="RosAria" respawn="true" output="screen"/>

</launch>

I get the error:

ERROR: cannot launch node of type [ROSARIA/RosAria]: ROSARIA

ROS path [0]=/opt/ros/groovy/share/ros

ROS path [1]=/home/acp/patrol_ws/sandbox

ROS path [2]=/opt/ros/groovy/share

ROS path [3]=/opt/ros/groovy/stacks

ROS path [4]=/home/acp/patrol_ws

ROS path [5]=/home/acp/patrol_ws/skynetish/generic_teleop

Any clue about this?

I appreciate your help

edit retag flag offensive close merge delete

Comments

Try out p2os-vanderbilt. It's stable in groovy. http://www.ros.org/wiki/p2os-vanderbilt

allenh1 gravatar imageallenh1 ( 2013-07-11 05:18:06 -0600 )edit

is the folder in which the ROSARIA is located added to $ROS_PACKAGE_PATH variable?

arp gravatar imagearp ( 2013-08-03 04:30:56 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-09-21 21:29:23 -0600

Edward Chow gravatar image

Hey Man: Maybe I know what is wrong with your launch file. In my opinion, the value of the pkg attribute should be "rosaria" rather than "ROSARIA" becuz the name of the directory u put your source code in is "rosaria" . So if u change the value to "rosaria" ,the problem will be solved. Hope u success!Best wishes~

Edward Chow

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-07-10 23:46:38 -0600

Seen: 352 times

Last updated: Sep 21 '14