Ask Your Question
0

rosaria installation errors on raspberry pi 3 -

asked 2016-10-16 23:38:47 -0500

updated 2016-10-17 01:08:45 -0500

Hi, I am using Raspberry Pi 3 under ubuntu mate 16.04 with ROS Kinetic (because raspbeian was not working for my setup). It worked perfectly fine and even better than when I did it under raspbein with ROS debian. But I am having a little problem.

First of all, when I tried to install ROSARIA through their official tutorial given here. However, as the tutorials are written for intel/amd processor, I am unable to follow it. In particulary, after running

cd ~/catkin_ws/src
git clone https://github.com/amor-ros-pkg/rosaria.git
cd ..
catkin_make

I get the following error

/catkin_ws/src/rosaria/LaserPublisher.cpp:5:25: fatal error: Aria/Aria.h: No such file or directory

I really wonder why that problem was occuring because I have done this on ROS-Kinetic under ubuntu 16.04 and ROS-Indigo under Ubuntu 14.04 and it worked fine.

edit 1: It is also worth mentioning that I have been trying to install rosaria software through their official page (link) but I realized that all the given software are based on either ubuntu amd/intel processors. And so, I could not install any of them because I was seeing error of compatibility. I was seeing error that I cannot install because it was not compatible.

Please, suggest me what should I do. Thanks in advance for your help.

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2016-10-22 05:45:30 -0500

updated 2016-10-22 05:51:31 -0500

OK, it worked. Although approach was the same, method was different. I followed these tutorials (link). Main problem was that Raspberry Pi 3 is an arm based architecture and all of the Aria Softwares (link) are based on intel/amd processor based architecture. So, here is what I did. It is important to mention that I was using ubuntu 16.06 mate and ROS-Kinetic.

The steps are as follows.

  • Follow the tutorial (link) till the software installation (Aria).
  • Download Aria (link)

  • Go to the download directory

  • run sudo dpkg --force-all -i libaria_2.9.0+ubuntu12+gcc4.6_amd64.deb

  • run make clean.

  • run make -j4

It is worth mentioning that here in this stage, my setup was failed but just to make sure, I rant it again and the second time it worked. It was installed by my colleague in another machine and he experienced the same which means that it worked on second time

  • go to the ros workspace cd ~/catkin_ws

  • Run catkin_make --force-cmake

So, it worked.

Thanks to ReedHedges for helping me out. From his post above, I got the clue to resolve this issue.

edit flag offensive delete link more

Comments

Great. Did you have any errors compiling ARIA on the Raspberry Pi?
ARIA 2.9.1 was just released, and with it are source-only packages you could use instead of dpkg -i --force-all. (Ubuntu 16.04 binary packages for both i386 and amd64 are now available as well.)

ReedHedges gravatar image ReedHedges  ( 2016-10-25 11:19:06 -0500 )edit

Also note that the make clean and make commands after installing ARIA should be done inside the ARIA directory.

ReedHedges gravatar image ReedHedges  ( 2016-10-25 11:19:33 -0500 )edit

Yes. It worked fine. I used Aria 2.9.1. First time when I compiled, it gave me errors but second time, it worked. I have written down exactly what I did. I appreciate your valuable suggestion Sir. Thank you so much ReehHedges.

Abdul Mannan gravatar image Abdul Mannan  ( 2016-10-26 08:30:40 -0500 )edit
1

answered 2016-10-20 08:50:25 -0500

ReedHedges gravatar image

You will need to (re)compile ARIA on the Raspberry Pi. You can either force installation of an Intel package or get the "generic compressed tar archive". (Upcoming release of ARIA will have a "source only" tarball as well.) Then go into the ARIA directory (/usr/local/Aria if installed) and run make clean then make. The rosaria scripts should check whether ARIA has already been installed in /usr/local/Aria before trying to install it via rosdep or other installation method. (Might need to use catkin_make --force-cmake) I've only played a bit superficially with an older Raspberry Pi so would be interested in any issues or feedback on using yours with a Pioneer robot. (I have been thinking about making it easier to cross-compile ARIA on a separate build machine as well, if that might help?)

edit flag offensive delete link more

Comments

Dear for the excelent tutorial and how to implement on Rasberry Pi with Pioneer under the ARIA library. However, I followed the steps mentioned above, but those do not make work my compilation. The link ARIA download a .deb. I downloaded the source code and compiled as said. When I make catkin_make

javier gravatar image javier  ( 2017-07-03 17:12:51 -0500 )edit

-force-cmake the compilation block my raspbarry pi 3. What I have to do?.

Greatings!

javier gravatar image javier  ( 2017-07-03 17:13:38 -0500 )edit
0

answered 2016-10-17 07:46:41 -0500

gijsje170 gravatar image

Maybe this will answer your question? getting-ariah-file-not-found-when-installing-rosaria

edit flag offensive delete link more

Comments

Thanks for your help. That thread is still open. I have already gone through it but no vain. Raspberry Pi 3 architecture is based on ARM processors. Solutions are only available for intel based processor architecture.

Abdul Mannan gravatar image Abdul Mannan  ( 2016-10-19 00:09:54 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-10-16 23:38:47 -0500

Seen: 860 times

Last updated: Oct 22 '16