Ask Your Question
2

pcd_viewer crashes after installing electric [closed]

asked 2011-10-07 13:37:55 -0500

updated 2011-10-07 14:00:37 -0500

aa755@abhishekHPUbuntu:~$ rosrun pcl_visualization pcd_viewer fridge.pcd

Loading fridge.pcd /opt/ros/electric/stacks/perception_pcl_addons/pcl_visualization/bin/pcd_viewer: symbol lookup error: /opt/ros/electric/stacks/perception_pcl_addons/pcl_visualization/bin/pcd_viewer: undefined symbol: _ZN17pcl_visualization28PCLVisualizerInteractorStyle3NewEv

I have unstable, diamondback and electric installed. but my .bashrc sets the environment variables for electric source /opt/ros/electric/setup.bash

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by kwc
close date 2012-02-29 07:43:22

Comments

+1 I have the same problem when trying to run pcd_viewer with downloaded RoboEarth models.
Pi Robot gravatar image Pi Robot  ( 2011-10-09 01:54:02 -0500 )edit

Closing question as there is no activity from OP

kwc gravatar image kwc  ( 2012-02-29 07:43:15 -0500 )edit

5 Answers

Sort by ยป oldest newest most voted
1

answered 2011-10-18 16:07:08 -0500

DanDee gravatar image

The viewer works fine, but the viewpoint was off - the object being viewed was way off the edge of the visible windows. Randomly moving the mouse around, or using the "r" key brought it back into view.

edit flag offensive delete link more
1

answered 2011-10-19 11:58:07 -0500

DanDee gravatar image

The pcd_viewer and pcd_viewer_simple from opt/ros/electric/stacks/perception_pcl/pcl/bin work fine. The displayed image is sized to the display window and oriented correctly. The versions of pcd_viewer and pcd_viewer_simple (and bag_viewer_simple) from perception_pcl_addons/pcl_visualization/bin have the image far off screen and it's rotated around a horizontal axis that's parallel to the display's glass (mirrored top/bottom, mirrored towards user / away from user.

edit flag offensive delete link more
1

answered 2011-10-18 15:30:59 -0500

DanDee gravatar image

I think that part of the problem is that both perception_pcl/pcl and perception_pcl_addons/pcl_visualization produce libraries called "libpcl_visualization.so". The linker sees the version from perception_pcl/pcl first, so ignores the one from perception_pcl_addons/pcl_visualization.

I messed around with renaming the library from perception_pcl_addons/pcl_visualization to be libpcl_visualization_addons.so. That fixed the undefined variables, but pcd_viewer and pcd_viewer_simple both produce blank screens. Well, pcd_viewer_simple has the nice red, blue, green axes that follow the mouse, but that's all. The same .pcd files (from bag_to_pcd) worked fine on a colleague's CloudViewer from the PCL windows download (I'm on Ubuntu 11.04).

edit flag offensive delete link more
0

answered 2011-10-16 12:52:01 -0500

lisherwin gravatar image

I am encountering the same problem as well. I get the same error when I try to run the electric pcd_viewer on my .pcd file. I am running Natty Ubuntu 11.04. Any help here?

edit flag offensive delete link more
0

answered 2012-01-05 01:52:08 -0500

Moataz Elmasry gravatar image

@lisherwin did you try the suggested solution to use the pcd_viewer inside pcl package instead of pcl_vidsualization. I had the same problem and this answer helped me

Otherwise you can also try to rename the pcd_viewer.so to something else, maybe this helps

edit flag offensive delete link more

Question Tools

Stats

Asked: 2011-10-07 13:37:55 -0500

Seen: 486 times

Last updated: Jan 05 '12