Ask Your Question
3

Installing ROS on Ubuntu 11.10 Oneric Ocelot

asked 2011-10-05 01:11:58 -0500

updated 2014-01-28 17:10:29 -0500

ngrennan gravatar image

Is actually possible to install ROS on the upcoming Ubuntu 11.10 Oneric Ocelot through the ros repository?

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
1

answered 2011-10-05 02:03:17 -0500

joq gravatar image

updated 2011-10-05 12:15:50 -0500

No Ubuntu Oneric packages are currently in the repository.

I would not expect to see them there until after Oneric is officially released by Ubuntu.

The answer above refers to the Ubuntu binaries. You can probably check out ROS sources and compile them on Oneric. There may be some problems with system dependencies or perhaps a new compiler version. If so, please report them. The ROS package maintainers will want to fix them.

edit flag offensive delete link more

Comments

Ok. I think that I can wait for a week. :)
thek3nger gravatar image thek3nger  ( 2011-10-05 02:05:13 -0500 )edit
Oneiric debs have been built and are now available.
tfoote gravatar image tfoote  ( 2011-11-09 19:40:54 -0500 )edit
1

answered 2011-10-31 06:04:43 -0500

Steven gravatar image

I have tried to follow the ROS installation instructions for Ubuntu 11.04 on my machine that is running Ubuntu 11.10. I can install the "bare bones" version ok but none of the higher functionality. I think the problem is the dependency on something called libglut3-dev. I tried installing each section of ROS individually and tracked the problem to this library. Can the ROS package maintainers help me get the full version installed on Ubuntu 11.10?

edit flag offensive delete link more

Comments

Using the natty 11.04 binaries might get you somewhere, but the oneiric 11.10 binaries are now mostly there. We are working on bringing them all up to date, but each package must be checked and if a change is required rereleased. Current status is at http://www.ros.org/debbuild/electric.html
tfoote gravatar image tfoote  ( 2011-10-31 06:18:02 -0500 )edit
0

answered 2011-11-09 15:58:57 -0500

Mike gravatar image

I am new to this but just installed Ubuntu (11.10) and was following the step-by-step ROS installation instructions. All fine until I got to the install ros-cturtle-pr2all step. This generated a long list of unmet dependencies. I tried looking through the links about available packages for 11.10, but couldn't figure it out. Maybe not every ready yet at 11.10 for pr2all?
Mike

edit flag offensive delete link more

Comments

cturtle is not specified to be installed on Oneiric The target platforms can be found at http://www.ros.org/reps/rep-0003.html#c-turtle-aug-2010
tfoote gravatar image tfoote  ( 2011-11-09 19:15:25 -0500 )edit
What instructions were you following?
tfoote gravatar image tfoote  ( 2011-11-09 19:40:26 -0500 )edit
Is there an ETA for the ros-electric-pr2-desktop package under 11.10 Oneiric? The documentation at http://www.ros.org/wiki/Robots/PR2/electric lists ros-electric-pr2-desktop as the top level package to get. But of course, apt-get does not find it.
paepcke gravatar image paepcke  ( 2011-11-13 10:35:09 -0500 )edit
0

answered 2011-11-02 09:11:12 -0500

prithvi gravatar image

The Deb build link shows that most of the packages are built without errors. Although no package repository is up for 11.10, does it mean that all of the packages without error work properly and a work around is to install ros electric through Natty repository ? or would it not work that way ?

edit flag offensive delete link more

Comments

The oneiric debs are up and functional as shown in the link you posted you can browse the available packages at http://packages.ros.org/ros/ubuntu/dists/oneiric/
tfoote gravatar image tfoote  ( 2011-11-02 20:16:49 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-10-05 01:11:58 -0500

Seen: 1,001 times

Last updated: Nov 09 '11