Ask Your Question
1

move_arm_joint_goal

asked 2011-09-21 02:11:36 -0600

Wouter gravatar image

Hi,

I am trying to perform the move_arm tutorials for the pr2. Once I run ./bin/move_arm_joint_goal in the 'simple_armstack_goals' package I am getting the following error:

Do you have any idea what causes this error?

I using ROS Electric on Ubuntu 11.04.

edit retag flag offensive close merge delete

Comments

The error did somehow not occur: [ERROR] [1316612972.596361511, 2.494000000]: Client [/move_right_arm] wants topic /move_right_arm/goal to have datatype/md5sum [arm_navigation_msgs/MoveArmActionGoal/d560cc046d6b5e8bf3f70a960054d6c6], but our version has [move_arm_msgs/MoveArmActionGoal/9b271f91d996a
Wouter gravatar imageWouter ( 2011-09-21 02:53:03 -0600 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2011-09-21 03:27:31 -0600

You should check that both the client (your program) and the robot are running the same version of ROS. If you switched from diamondback to electric many packages should at least be recompiled.

Also be sure that you are sourcing the right setup.bash file (usually /opt/ros/electric) in your .bashrc.

Electric has a diferent structure for the arm_navigation, so probably this is the cause of your error.

edit flag offensive delete link more

Comments

I am using electric and have /opt/ros/electric in my .bashrc. So do you mean that the ompl_ros_interface tutorials do not work in electric anymore? I recompiled the packages that are needed for the ompl_ros_interface tutorials but the error still remains there.
Wouter gravatar imageWouter ( 2011-09-21 07:10:29 -0600 )edit
Lorenzo is right, the error means that the two nodes communicating over the topic were compiled using two different versions of the MoveArmActionGoal message. Run `env | grep ROS`, check ROS_ROOT and ROS_PACKAGE_PATH and run rosmake on all involved packages.
Martin Günther gravatar imageMartin Günther ( 2011-09-22 01:50:30 -0600 )edit
You're both right, after re-compiling all involved packages it worked. I forgot one package previously. Thanks or your help!
Wouter gravatar imageWouter ( 2011-09-25 19:49:58 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-09-21 02:11:36 -0600

Seen: 113 times

Last updated: Sep 21 '11