Ask Your Question
1

TurtleBot BringUp Errors

asked 2011-08-28 07:46:55 -0500

comebackdan gravatar image

updated 2011-09-02 10:18:29 -0500

mmwise gravatar image

Hi everyone, (Warning: I'm new to TurtleBot, ROS, and UBUNTU)

I'm having trouble bringing up my TurtleBot. I installed Ubuntu 11.04 Natty and ROS on my Laptop/TurtleBot and my Workstation. I setup the network settings, but skipped making a VPN. I made it as far as SSH-ing into my Laptop/TurtleBot.

Here is my Play by Play

1) Turn on Laptop, log in, close lid, plug into TurtleBot/Kinect, turn on iCreate

2) Turn on Workstation, open terminal,

3) type: ssh turtlebot@192.168.2.106

4) type: sudo service turtlebot start

ERROR MSG: turtlebot: unrecognized service

5) I also get an error when I attempt to bring up the TurtleBot Dashboard

TurtleBot Error

Does anyone know where I should start in fixing these issues?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
5

answered 2011-08-28 11:08:37 -0500

mmwise gravatar image

If you didn't use the TurtleBot ISO to install your laptop the service is not automatically installed. To install the service:

roscd turtlebot_bringup/upstart

Now install the service by running the install script. (the README file in the directory will also give you tips)

sudo ./install.bash

if you are using a special interface like tethering to an android tablet or using openvpn then you can provide the interface in the command line:

sudo ./install.bash interface(i.e. tun0 or usb0)
edit flag offensive delete link more

Comments

For the dashboard you need to install and run that on your workstation or run ssh with x-forwarding use the '-X' option.
tfoote gravatar image tfoote  ( 2011-08-28 13:56:32 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-08-28 07:46:55 -0500

Seen: 1,314 times

Last updated: Sep 02 '11