Ask Your Question
1

openni kinect gazebo no depth data

asked 2011-08-18 00:36:48 -0500

Moataz Elmasry gravatar image

Hello

I'm trying to use the simulated kinect in gazebo, I just copy pasted the gazebo kinect snippet used in turtlebot and adapted it to my needs. the topic /camera/image_raw is publishing and I can see the image in rviz On the other hand no point cloud is being published on /camera/depth/points, The topic has been started, just no data are published on it. Any ideas? Regards, Moataz

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
3

answered 2011-08-18 10:19:47 -0500

hsu gravatar image

updated 2011-08-18 10:21:31 -0500

Assuming you are on electric...

I am not sure about the missing image views in rviz, but w.r.t. the point clouds, you have just discovered a bug in the threshold logic based on connected clients in the gazebo_ros_camera plugin. It's fixed in trunk. One temporary hack around this bug is to:

  1. make sure no one is subscribed to the image_raw ros topic.
  2. now subscribe to the points topic

I'll shoot for a new release very soon. sorry about the breakage.

John

edit flag offensive delete link more

Comments

are you talking about the snippet gazebo_ros_openni_kinect.cpp::updatechild(). if (!this->myParent->IsActive()) { // do this first so there's chance for sensor to run 1 frame after activate if (this->pointCloudConnectCount > 0) { this->myParent->SetActive(true); this->myParent->SimulateDepthData(true); } else if (this->imageConnectCount > 0) { this->myParent->SimulateDepthData(false); this->myParent->SetActive(true); } }
Moataz Elmasry gravatar imageMoataz Elmasry ( 2011-08-18 20:59:33 -0500 )edit
when do you expect this fix to appear on unstable ubuntu repo?
Moataz Elmasry gravatar imageMoataz Elmasry ( 2011-08-18 23:14:03 -0500 )edit
I had originally fixed only gazebo_ros_camera, which would have not been enough... just pushed same changes for gazebo_ros_openni_kinect in trunk. Can someone else test it out and let me know it's working correctly before I make the final release? Thanks.
hsu gravatar imagehsu ( 2011-08-19 09:53:14 -0500 )edit
1

answered 2011-08-18 10:03:00 -0500

mmwise gravatar image

Are you running on electric or diamondback? The kinect plugin is only available in electric and not in diamondback.

edit flag offensive delete link more

Comments

I´m running on unstable
Moataz Elmasry gravatar imageMoataz Elmasry ( 2011-08-18 21:05:27 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-08-18 00:36:48 -0500

Seen: 1,024 times

Last updated: Aug 18 '11