Ask Your Question
1

Some packages could not be installed

asked 2011-08-16 09:32:42 -0500

miivers gravatar image

updated 2014-01-28 17:10:13 -0500

ngrennan gravatar image

Hello

Windows user here which is taking a daring step into the world of Linux. I am trying to install diamondback under Ubuntu 10.10 OS which is not going my way. I keep getting messages about dependency problem but no information is given about what it needs. So fare I haven't found any logs which might help solving the problem.

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 ros-diamondback-desktop-full : Depends: ros-diamondback-ros-tutorials (= 0.2.4-s1312444428~maverick) but it is not going to be installed
                                Depends: ros-diamondback-geometry-tutorials (= 0.1.3-s1312444551~maverick) but it is not going to be installed
                                Depends: ros-diamondback-slam-gmapping (= 1.2.3-s1312434364~maverick) but it is not going to be installed
                                Depends: ros-diamondback-ros (= 1.4.9-s1312417704~maverick) but it is not going to be installed
                                Depends: ros-diamondback-visualization (= 1.4.1-s1312430955~maverick) but it is not going to be installed
                                Depends: ros-diamondback-vision-opencv (= 1.4.3-s1312425623~maverick) but it is not going to be installed
                                Depends: ros-diamondback-perception-pcl (= 0.10.0-s1312426677~maverick) but it is not going to be installed
                                Depends: ros-diamondback-rx (= 1.4.2-s1312429740~maverick) but it is not going to be installed
                                Depends: ros-diamondback-image-pipeline (= 1.4.2-s1312436357~maverick) but it is not going to be installed
                                Depends: ros-diamondback-simulator-gazebo (= 1.2.8-s1312439344~maverick) but it is not going to be installed
                                Depends: ros-diamondback-diagnostics-monitors (= 1.4.0-s1312438884~maverick) but it is not going to be installed
                                Depends: ros-diamondback-simulator-stage (= 1.2.5-s1312436791~maverick) but it is not going to be installed
                                Depends: ros-diamondback-image-common (= 1.4.1-s1312425497~maverick) but it is not going to be installed
                                Depends: ros-diamondback-common-tutorials (= 0.1.2-s1312462299~maverick) but it is not going to be installed
                                Depends: ros-diamondback-ros-comm (= 1.4.7-s1312424612~maverick) but it is not going to be installed
                                Depends: ros-diamondback-visualization-common (= 1.4.2-s1312429916~maverick) but it is not going to be installed
                                Depends: ros-diamondback-physics-ode (= 1.4.1-s1312429433~maverick) but it is not going to be installed
                                Depends: ros-diamondback-driver-common (= 1.2.3-s1312425422~maverick) but it is not going to be installed
                                Depends: ros-diamondback-executive-smach (= 1.0.2-s1312434262~maverick) but it is not going to be installed
                                Depends: ros-diamondback-common-msgs (= 1.4.0-s1312424894~maverick) but it is not going to be installed
                                Depends: ros-diamondback-image-transport-plugins (= 1.4.1-s1312426360~maverick) but it is not going to be installed
                                Depends: ros-diamondback-robot-model (= 1.4.0-s1312427507~maverick) but it is not going to be installed
                                Depends: ros-diamondback-visualization-tutorials (= 0.2.2-s1312463900~maverick) but it is not going to be installed
                                Depends: ros-diamondback-geometry (= 1.4.2-s1312425145~maverick) but it is not going to be installed
                                Depends: ros-diamondback-documentation (= 1.4.1-s1312464016~maverick) but it is not going to be installed
                                Depends: ros-diamondback-executive-smach-visualization (= 1.0.1-s1312458275~maverick) but it is not going to be installed
                                Depends: ros-diamondback-laser-pipeline (= 1.2.0-s1312428954~maverick) but it ...
(more)
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2011-08-17 07:27:51 -0500

miivers gravatar image

Thanks for the info. I found a old version of ros for Ubuntu 10.04. I do not know if this made a conflict. I removed everything related to ros in synaptic packet manager and all update entry's related to ros under Software Sources. After this everything went fine when I followed the install guide again.

edit flag offensive delete link more
0

answered 2011-08-16 10:22:09 -0500

tfoote gravatar image

Often you get a message like this if your package index is out of date. Try calling sudo apt-get update before your apt-get install command.

Also I assume you're following the Ubuntu installation guide double check that you've followed each step.

Also this video is targeted for the TurtleBot, but follows almost exactly the same installation path.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-08-16 09:32:42 -0500

Seen: 2,453 times

Last updated: Aug 17 '11