ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

fovis odometry failed: NO_DATA

asked 2013-11-03 04:21:12 -0600

maysamsh gravatar image

updated 2016-10-24 08:35:27 -0600

ngrennan gravatar image

I'm trying to get 3D odometry data using fovis, but seems it does not work, because I face bunch of errors:

    [ERROR] [1383492092.322748950]: fovis odometry failed: NO_DATA
    [ERROR] [1383492112.108683377]: fovis odometry failed: REPROJECTION_ERROR
    [ERROR] [1383492112.464506236]: fovis odometry failed: INSUFFICIENT_INLIERS
    [ERROR] [1383492112.533878210]: TF_NAN_INPUT: Ignoring transform for child_frame_id "/camera_rgb_optical_frame" from authority "/mono_depth_odometer" because of a nan value in the transform (nan nan nan) (nan nan nan nan)

First of all, I run roslaunch openni_launch openni.launch, Then I run rosrun fovis_ros mono_depth_odometer _base_link_frame_id:=/camera_rgb_optical_frame.

How can I fix it?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2013-12-03 14:37:36 -0600

sai gravatar image

updated 2013-12-03 14:40:14 -0600

First try without giving any parameter. As far as I remember, it worked without any parameter for kinect.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2013-11-03 04:21:12 -0600

Seen: 379 times

Last updated: Nov 03 '13