Ask Your Question
9

rqt plugin not listed/found in list returned by "rqt --list-plugins"

asked 2013-10-15 08:51:32 -0500

Gripen gravatar image

updated 2013-11-14 11:49:03 -0500

tfoote gravatar image

I am writing a rqt plugin (ROS Hydro, Ubuntu 12.04.3 LTS, x86_64) at moment following the rqt tutorial: Create your new plugin.

Unfortunately, my plugin is not in the list returned by "rqt --list-plugins". rosrun also fails.

$ cd ~/rqt_ws/

$ catkin_make

$ rosrun rqt_mypkg rqt_mypkg

qt_gui_main() found no plugin matching "rqt_mypkg"

edit retag flag offensive close merge delete

Comments

I'm having the same issue using ROS Groovy. Everything builds and installs properly, but I can't run the plug-in. I can even open and build it without issue in QT Creator. I'm currently running off of the binary packages. Any advice?

Chief_534 gravatar imageChief_534 ( 2013-10-17 07:54:19 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
25

answered 2013-10-16 01:19:26 -0500

markpitchless gravatar image

updated 2013-10-31 06:40:36 -0500

Appears to be a problem with rqt caching the locations of plugins in its config and not updating that info. A workaround that works for me is delete that cache and restart rqt:

$ rm ~/.config/ros.org/rqt_gui.ini
$ rqt

A 2nd workaround: this appears to work using the latest rqt source (groovy-devel branch, which is also used to build the hydro packages), so this looks like a bug in the released packages as opposed to a problem with the tutorial. I added the following to my hydro workspace:

- git: {local-name: qt_gui_core, uri: 'git@github.com:ros-visualization/qt_gui_core.git'}
- git: {local-name: rqt, uri: 'git@github.com:ros-visualization/rqt.git'}
- git: {local-name: rqt_common_plugins, uri: 'git@github.com:ros-visualization/rqt_common_plugins.git'}

and a new plugin was found and ran.

edit flag offensive delete link more

Comments

1

I have the same setup as the initiator (ROS Hydro, Ubuntu 12.04.3 LTS, x86_64) and face exactly the same problem. Also overlaying the proposed meta-packages did not solve the problem.

Frederik gravatar imageFrederik ( 2013-10-26 07:26:29 -0500 )edit

This might be a bug. Follow this issue for details: https://github.com/ros-visualization/rqt/issues/90 .

bit-pirate gravatar imagebit-pirate ( 2013-11-04 14:21:56 -0500 )edit

Thank you very much ! The problem had confused me a long time .

zsbhaha gravatar imagezsbhaha ( 2014-04-19 18:50:35 -0500 )edit

I am having the same problem. When you say you've added this to your hydro workspace, how exactly is that done. I am working in ROS Groovy.

dennis.tryk gravatar imagedennis.tryk ( 2014-08-06 03:09:31 -0500 )edit
6

If you follow the bug in question, the fix for this is to add the --force-discover option when running rqt.

ahendrix gravatar imageahendrix ( 2014-08-06 03:58:59 -0500 )edit

Just want to say thank you ! I even tried to reinstall ros but doesn't work. Because the config file never been removed....

Mike Zobot gravatar imageMike Zobot ( 2018-04-20 14:06:37 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

4 followers

Stats

Asked: 2013-10-15 08:51:32 -0500

Seen: 8,015 times

Last updated: Oct 31 '13