ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

RQT command does not display plugins after clean install

asked 2018-03-24 14:40:16 -0600

Coppermind gravatar image

updated 2018-03-24 15:02:25 -0600

gvdhoorn gravatar image

Hello, I am working with Ubuntu 16.04 and ros kinetic. I am trying to experiment with Ros QT for designing an interface for my project. I haven't been able to get the rqt command to display the plugins that I have installed.

I am a ROS newbie, so it is plausible that I made a mistake with how I installed rqt, but what I did was that I started with a clean install of Ubuntu 16.04, I followed the instructions listed here: and here to verify ROS was installed correctly.

I then ran the commands

$ sudo apt-get install ros-kinetic-rqt ros-kinetic-rqt-common-plugins

$ sudo apt-get update

$ sudo apt-get dist-upgrade

as instructed here

When I run the command


I only get a blank window with no text.

I tried to verify that I had plugins installed by running

$ rqt --list-plugins

and I do get a populated list, and I can run the 'rqt_image_view' plugin directly from the command line.

My question is why do I not see any options to run plugins from the rqt window? Any insight or advice would be greatly appreciated.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted

answered 2018-03-24 15:05:31 -0600

130s gravatar image

On my 16.04 I see menus on the Ubuntu's top panel, not on rqt's window (I think the default appearance changed sometimes between 14.04 and 16.04?).

Seems like you can change that setting on Ubuntu's level, see this example.

edit flag offensive delete link more


This could very well be the cause here.

gvdhoorn gravatar image gvdhoorn  ( 2018-03-24 15:07:18 -0600 )edit

This did turn out to be the issue, thank you for your help.

Coppermind gravatar image Coppermind  ( 2018-03-24 15:25:02 -0600 )edit

This worked. Such a simple issue. Thanks a lot!!

ishwar gravatar image ishwar  ( 2019-11-17 19:10:40 -0600 )edit

what? I don"t understand what this means

Kansai gravatar image Kansai  ( 2021-01-06 22:16:13 -0600 )edit

answered 2018-03-24 15:06:02 -0600

gvdhoorn gravatar image

Try to run rqt with the --force-discover option. Some times a cache needs to be updated.

Related question: #q166851.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2018-03-24 14:38:11 -0600

Seen: 5,235 times

Last updated: Mar 24 '18