Ask Your Question
1

openni2_tracker problems

asked 2013-10-09 21:54:18 -0600

CarolineQ gravatar image

updated 2013-10-09 21:55:31 -0600

Hi !

I am currently using ROS Groovy and I recently decided to move from openNI 1.5 to openNI 2.

I tried openni2_tracker and managed to make it work, but I have two problems :

  • The node needs to find data file ./Nite2/s.dat, so it's not working if you don't run it from a specific directory. Which means you can not put it in a launch file you want to run from anywhere on your system. Is it a normal thing ?

  • It's not possible to launch the script openni2.launch (with all sensor driver) and openni2_tracker at the same time. It's a problem for me because I would like to run other nodes using the camera data at the same time than openni2_tracker.

Does someone have some information ?

Thanks,

Caroline

edit retag flag offensive close merge delete

Comments

hello, sorry for bothering you but how did you run openni2_tracker - because i have a build issue with orocos_kdl ?

sparksmith gravatar imagesparksmith ( 2014-03-06 08:00:00 -0600 )edit

I have the same problem with ROS Hydro. It is not possible to use openni2.launch togheter with openni2_tracker

rastaxe gravatar imagerastaxe ( 2014-09-18 11:10:58 -0600 )edit

i am using kinect with windows 10, facing same problem.Please can any one solve this error.Thanks in advance

manideep gravatar imagemanideep ( 2016-06-08 11:07:55 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2016-07-07 12:30:43 -0600

Pototo gravatar image

Go into the folder where Nite2/s.dat. In my case I installed nite2 in my home directory, so I ran openni2_tracker node from inside this path:

~/NiTE-2.0.0/Redist/

Therefore, s.dat is locate here "~/NiTE-2.0.0/Redist/NiTE2/s.dat" Openni2_tracker will work in that way. It's kinda lame, though. There's gotta be a better way to have the ros node understand the path. The path is allegedly provided through the CMakelist of the openni2_tracker package, but that does not seem to fully work. You must figure how to provide the path in correctly in your CMakeList file.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-10-09 21:54:18 -0600

Seen: 1,257 times

Last updated: Jul 07 '16