Ask Your Question
1

My kinetic camera stop working (no device detected)

asked 2014-01-07 07:36:30 -0500

rnunziata gravatar image

updated 2016-10-24 08:35:39 -0500

ngrennan gravatar image

update: assuming there are no USB 2.0 to 3.0 adapters since 3.0 was to be compatabile does ubuntu 13.10 updated kernel off any hope. I am running 13.04

update: tried to reinstall everything then run freenect launch. I get the following first waiting message then I plug the device in and get what follows. The USB ports are 3.0

[ INFO] [1390668700.050552116]: No devices connected.... waiting for devices to be connected
[ INFO] [1390668703.054328712]: Number devices connected: 1
[ INFO] [1390668703.054588759]: 1. device on bus 000:00 is a Xbox NUI Camera (2ae) from Microsoft (45e) with serial id '0000000000000000'
[ INFO] [1390668703.056447295]: Searching for device with index = 1
[ INFO] [1390668703.095462065]: No matching device found.... waiting for devices. Reason: [ERROR] Unable to open specified kinect

Update: There seems to be some dissusion on a share lib causing some issues: I looked for it on my machine and it looks a bit confused any thought this.

sudo glview
glview: error while loading shared libraries: libfreenect.so.0.2: cannot open shared object file: No such file or directory
viki@viki:~$ glview
Kinect camera test
Number of devices found: 1
Could not open device


sudo find / -name libfreenect.so -ls
15341498    0 lrwxrwxrwx   1 viki     viki           18 Jan 11 13:08 /home/viki/catkin_ws/src/KinectLibs/libfreenect/build/lib/fakenect/libfreenect.so -> libfreenect.so.0.2
12716955    0 lrwxrwxrwx   1 viki     viki           18 Jan 11 13:08 /home/viki/catkin_ws/src/KinectLibs/libfreenect/build/lib/libfreenect.so -> libfreenect.so.0.2


11141534    0 lrwxrwxrwx   1 root     root           18 Oct  9 21:08 /opt/ros/hydro/lib/fakenect/libfreenect.so -> libfreenect.so.0.1
10883699    0 lrwxrwxrwx   1 root     root           18 Oct  9 21:08 /opt/ros/hydro/lib/libfreenect.so -> libfreenect.so.0.1
9438521    0 lrwxrwxrwx   1 root     root           18 May 25  2012 /usr/lib/x86_64-linux-gnu/fakenect/libfreenect.so -> libfreenect.so.0.1
7355096    0 lrwxrwxrwx   1 root     root           18 May 25  2012 /usr/lib/x86_64-linux-gnu/libfreenect.so -> libfreenect.so.0.1

7480477    0 lrwxrwxrwx   1 root     root           18 Jan 11 13:08 /usr/local/lib64/fakenect/libfreenect.so -> libfreenect.so.0.2
7357524    0 lrwxrwxrwx   1 root     root           18 Jan 11 13:08 /usr/local/lib64/libfreenect.so -> libfreenect.so.0.2
viki@viki:~$

Update: There is a CD with my kinetic. Is there anything useful in this to address this issue?

Update: If I unplug the device and run glview again I get: From what I can see this is a known problem with the linux kernel since 2012 but little has been done to address it. I tried several solutions in the blogs but non seem to work

Kinect camera test
Number of devices found: 0

Update: I tried the following utility

freenect-glview 
Kinect camera test
Number of devices found: 1
Could not open device

Update: lsusb -v

Bus 003 Device 021: ID 045e:02ae Microsoft Corp. Xbox NUI Camera
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass            0 ...
(more)
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
3

answered 2014-01-25 06:33:41 -0500

It sounds like you have USB 3.0 problems, since you can't use the Kinect on a USB 3.0 port (in general, sometimes it just works, sometimes it doesn't). Is it possible to disable USB 3.0 in your BIOS on a Mac? If not, try changing UsbInterface in /etc/openni/GlobalDefaults.ini to some other value (just try the four other options).

edit flag offensive delete link more

Comments

Oh wow, I didn't even see that the first time. But he said that it had worked before I think. Anyways, yes. 3.0 = no bueno.

Athoesen gravatar imageAthoesen ( 2014-01-25 06:47:51 -0500 )edit

Yeah I don't know why it would suddenly stop working...that happened to me once, I never found out the root problem, but it was fixed by changing the UsbInterface field. Maybe some kind of Kernal update?

Tim Sweet gravatar imageTim Sweet ( 2014-01-25 06:57:10 -0500 )edit

The USB line from my Mac GlobalDefaults.ini ; USB interface to be used. 0 - FW Default, 1 - ISO endpoints, 2 - BULK endpoints. Default: Arm - 2, other platforms - 1 Any one look better then the others?

rnunziata gravatar imagernunziata ( 2014-01-25 08:53:44 -0500 )edit

A USB 3.0 to 2.0 adapter won't work, I've tried that with a USB 2.0 hub. I suggest just trying each one of those interfaces, the GlobalDefaults file is loaded when OpenNI is run (ie with roslaunch openni_launch or your own variant) so just modify the file, try to start it, repeat.

Tim Sweet gravatar imageTim Sweet ( 2014-01-25 13:46:01 -0500 )edit

Your update with the most recent output tells me the interface (from GlobalDefaults.ini) might be the problem: it seems able to identify the camera on the bus, but won't get its serial number so it can't talk to the camera. Can you disable USB 3.0 in OpenFirmware (see: http://goo.gl/XJpAvQ)?

Tim Sweet gravatar imageTim Sweet ( 2014-01-25 13:50:04 -0500 )edit

Thanks Tim. I have been scanning for any info on how to turn off/on usb in the BIOS. Not something I normally do and would be great to see instructions or a demo. But I can not seem to find anything. Any idea where I can look?

rnunziata gravatar imagernunziata ( 2014-01-26 02:41:42 -0500 )edit

I've never owned a Mac so I have no clue..I only use one for video editing :) I'll ask around in my lab and see if anyone knows. It might not be possible. Did the UsbInterface thing not work?

Tim Sweet gravatar imageTim Sweet ( 2014-01-26 07:04:39 -0500 )edit

I came across this which is encouraging but does not tell me how to do this on a mac. http://rog.asus.com/forum/showthread.php?37159-How-do-I-disable-or-delete-the-USB-3.0-drivers. Thank you .

rnunziata gravatar imagernunziata ( 2014-01-26 08:54:51 -0500 )edit
0

answered 2014-01-08 05:18:17 -0500

Athoesen gravatar image

updated 2014-01-08 06:30:45 -0500

I just use @zero so that it will default to the correct number. It works for me with openni_launch, you might be experiencing an openni2 problem. Try this:

roslaunch openni_launch openni.launch device_id:=3@0

Your lsusb looks pretty normal, I think the computer is detecting a camera fine. Make sure you run lsusb after you've connected but before you try roslaunch openni_launch to ensure you're on the proper bus.

Edit: Could you post a picture of your rqt_graph picture and roswtf results to see if there are any messages that aren't communicating properly? Also I'd check to see if there is anything else currently on the bus you're trying to use.

edit flag offensive delete link more

Comments

Thanks for looking....but still not working.

rnunziata gravatar imagernunziata ( 2014-01-08 06:26:55 -0500 )edit

How do I check to see what else is on bus...camera plugin it to usb port. Also this was working a month or so ago.

rnunziata gravatar imagernunziata ( 2014-01-08 06:38:07 -0500 )edit

1) Next time you insert an image I'd suggest uploading to imgur or a similar site and link so that it doesn't blow up the page. 2) You can see the list with the lsusb command like you used before. It appears from your previous listing that only the Kinect is on Bus 3 3) Is the Kinect plugged in?

Athoesen gravatar imageAthoesen ( 2014-01-08 07:33:09 -0500 )edit

Yes...its plugged in has green LED is on. I issue lsusb and use the port the camera is on in the above eg...that would be 3@4. Not the audio which is 3@3.

rnunziata gravatar imagernunziata ( 2014-01-08 07:48:08 -0500 )edit

Can you please modify the image so it doesn't fill the screen? Also, two other things. What computer are you using? And have you tried using bus 1 or 2? I noticed in all of your responses you keep trying usb ports on bus 3. If there is enough bandwidth, try another bus. Might be hardware.

Athoesen gravatar imageAthoesen ( 2014-01-09 08:00:29 -0500 )edit

I an new mac running Ubuntu in dual boot. I've tried both ports. And as I said it worked in the past. I tried uninstalling ros and re-installing did not work. I do not update the data on the question that is why the port is always the same. I have tried different ports.

rnunziata gravatar imagernunziata ( 2014-01-09 08:18:20 -0500 )edit

Ok, you've tried different ports but are they both still on bus 3? In other words, when you use -lsusb-, will they list it as Bus 003 each time? Other than this, I don't know what else it could be.

Athoesen gravatar imageAthoesen ( 2014-01-09 08:38:04 -0500 )edit

yes...I post lsusb with verbose in case it is helpfull

rnunziata gravatar imagernunziata ( 2014-01-09 08:53:39 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-01-07 07:36:30 -0500

Seen: 4,676 times

Last updated: Jan 25 '14