Ask Your Question
0

Using multiple Primesenes

asked 2013-12-01 13:01:25 -0500

AlphaOne gravatar image

Hello,

I am trying to use multiple PrimeSense sensors for a project. I am having trouble launching them as it appears they do not use deivce ID's like the Kinect does. I tried this launch file and got this error.

    <launch>

  <!-- Parameters possible to change-->
    <arg name="camera1_id" default="1d27/0601@2/3" /><!-- here you can change 1@0 by the serial number -->
    <arg name="camera2_id" default="1d27/0601@3/4" /><!-- here you can change 2@0 by the serial number -->
    <arg name="camera3_id" default="3@0" /><!-- here you can change 3@0 by the serial number -->
    <arg name="depth_registration" default="true" />

  <!-- Default parameters-->
    <arg name="camera1_name" default="primesense1" />
    <arg name="camera2_name" default="primesense2" />
    <arg name="camera3_name" default="primesense3" />

 <!-- Putting the time back to real time-->
    <rosparam>
       /use_sim_time : false
    </rosparam>

<remap from="image" to="/camera/depth/image_raw"/> <!--Correct remap for depthimage launch -->

<!-- Openning Rviz for visualization-->
<node pkg="rviz" type="rviz" name="rviz"
        args="-d $(find parbot_depthimage_to_laserscan)/rviz_cfg/parbot_demo.rviz"/><!--This will launch rviz with the configuration saved from rviz--> 

<!-- Launch depthimage with the proper parameters -->
    <node pkg="parbot_depthimage_to_laserscan" type="parbot_depthimage_to_laserscan" name="parbot_depthimage_to_laserscan">
        <param name="scan_height" value="471" />
    </node>

  <!-- Launching first kinect-->
    <include file="$(find openni2_launch)/launch/openni2.launch">
        <arg name="device_id" value="$(arg camera1_id)" />
        <arg name="camera" value="$(arg camera1_name)" />
        <arg name="depth_registration" value="$(arg depth_registration)" />
     </include>

 <!-- Launching second kinect-->
    <include file="$(find openni2_launch)/launch/openni2.launch">
        <arg name="device_id" value="$(arg camera2_id)" />
        <arg name="camera" value="$(arg camera2_name)" />
        <arg name="depth_registration" value="$(arg depth_registration)" />
     </include>

<!-- Launching third kinect
    <include file="$(find openni2_launch)/launch/openni2.launch">
    <arg name="device_id" value="$(arg camera3_id)" />
    <arg name="camera" value="$(arg camera3_name)" />
    <arg name="depth_registration" value="$(arg depth_registration)" />
    </include>-->

  </launch>

The error:

[ INFO] [1385943021.299596903]: No matching device found.... waiting for devices. Reason: std::string openni2_wrapper::OpenNI2Driver::resolveDeviceURI(const string&) @ /tmp/buildd/ros-hydro-openni2-camera-0.1.0-0precise-20131015-2304/src/openni2_driver.cpp @ 672 : Device not found 1d27/0601@2/3
[ INFO] [1385943021.889858369]: No matching device found.... waiting for devices. Reason: std::string openni2_wrapper::OpenNI2Driver::resolveDeviceURI(const string&) @ /tmp/buildd/ros-hydro-openni2-camera-0.1.0-0precise-20131015-2304/src/openni2_driver.cpp @ 672 : Device not found 1d27/0601@3/4

I'm not really sure where to go from here? Has it ever been done?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-12-03 10:17:46 -0500

AlphaOne gravatar image

I figured out that by using #1, #2, and #3 as the camera_id's that this is in fact possible.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-12-01 13:01:25 -0500

Seen: 426 times

Last updated: Dec 03 '13