Ask Your Question
0

Isn't the hector_quadrotor stack catkinized?

asked 2013-09-09 16:34:10 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Although the stack (and all the packages) seems to be catkinized I am unable to install the packages. Whenever I run the catkin_make command (after arranging the folder structure for catkin) the devel and install folder are not created.

the terminal output when I run catkin_make is

Base path: /home/saroj/ros/ros_ws

Source space: /home/saroj/ros/ros_ws/src

Build space: /home/saroj/ros/ros_ws/build

Devel space: /home/saroj/ros/ros_ws/devel

Install space: /home/saroj/ros/ros_ws/install ####

Running command: "make cmake_check_build_system" in "/home/saroj/ros/ros_ws/build"

#### ####

Running command: "make -j2 -l2" in "/home/saroj/ros/ros_ws/build"

#### saroj@saroj:~/ros/ros_ws$

(I have just started using ROS (even ubuntu) and I apologize if the question sounds stupid)

edit retag flag offensive close merge delete

Comments

What repository / branch have you checked out? Do the directories contain package.xml or manifest.xml files?

Dirk Thomas gravatar imageDirk Thomas ( 2013-09-10 05:10:49 -0500 )edit

I am using tu-darmstadt-ros-pkg/hector_quadrotor repository and hydro_devel branch. The directories do have manifest.xml...

espee gravatar imageespee ( 2013-09-10 05:16:19 -0500 )edit

There is your answer: it is not catkinized.

joq gravatar imagejoq ( 2013-09-10 05:26:32 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
3

answered 2013-09-10 23:12:20 -0500

There is a catkinized version of the hector_quadrotor stack now in the catkin branch (forked from hydro-devel):

https://github.com/tu-darmstadt-ros-pkg/hector_quadrotor/tree/catkin

It is still under development and some packages have been reorganized for hydro. There are plans to do some more tests, update the rviz configs etc. and then release hector_quadrotor in hydro, but there was no time for that until now.

We would be glad if you and others can test the catkin branch and report bugs or submit pull requests via the GitHub bugtracker.

edit flag offensive delete link more

Comments

Thank you so much. I will definitely try and report any problems I face.

espee gravatar imageespee ( 2013-09-11 01:20:51 -0500 )edit
1

answered 2013-09-10 05:27:50 -0500

Dirk Thomas gravatar image

If the directories contain manifest.xml files (instead of package.xml files) than the packages are not catkinized and still use the "old" rosbuild. Please use rosmake to build them.

edit flag offensive delete link more

Comments

Thanks for the answer.

espee gravatar imageespee ( 2013-09-10 05:47:14 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-09-09 16:34:10 -0500

Seen: 179 times

Last updated: Sep 10 '13