Ask Your Question
0

Problem running nao_driver on cross-compiled Nao

asked 2013-08-19 06:18:43 -0600

DavidLavy gravatar image

Hello,

I have cross-compiled ROS Groovy in my NAO V4, using this tutorial http://www.ros.org/wiki/nao/Installation/local. Now I'm following the instructions in here http://www.ros.org/wiki/nao_driver

But when I run the following command:

$ roslaunch nao_driver nao_driver.launch

I get this error


... logging to /home/nao/.ros/log/fd173254-08e5-11e3-a0ff-243c2007c59c/roslaunch-Jarvis-3374.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://Jarvis:54780/

SUMMARY

========

PARAMETERS * /rosdistro * /rosversion

NODES / nao_controller (nao_driver/nao_controller.py) nao_sensors (nao_driver/nao_sensors.py) nao_walker (nao_driver/nao_walker.py)

auto-starting new master process[master]: started with pid [3387] ROS_MASTER_URI=http://localhost:11311

setting /run_id to fd173254-08e5-11e3-a0ff-243c2007c59c process[rosout-1]: started with pid [3400] started core service [/rosout] process[nao_walker-2]: started with pid [3412] process[nao_sensors-3]: started with pid [3413] process[nao_controller-4]: started with pid [3414] Traceback (most recent call last): File "/opt/ros/groovy/lib/nao_driver/nao_walker.py", line 57, in <module> from nao_driver.util import startWalkPose ImportError: No module named util ================================================================================REQUIRED process [nao_walker-2] has died! process has died [pid 3412, exit code 1, cmd /opt/ros/groovy/lib/nao_driver/nao_walker.py --pip=127.0.0.1 --pport=9559 __name:=nao_walker __log:=/home/nao/.ros/log/fd173254-08e5-11e3-a0ff-243c2007c59c/nao_walker-2.log]. log file: /home/nao/.ros/log/fd173254-08e5-11e3-a0ff-243c2007c59c/nao_walker-2*.log

Initiating shutdown!

[nao_controller-4] killing on exit [nao_sensors-3] killing on exit [nao_walker-2] killing on exit Traceback (most recent call last): Traceback (most recent call last): File "/opt/ros/groovy/lib/nao_driver/nao_sensors.py", line 44, in <module> File "/opt/ros/groovy/lib/nao_driver/nao_controller.py", line 37, in <module> import rospy File "/opt/ros/groovy/lib/python2.7/site-packages/rospy/__init__.py", line 49, in <module> from nao_msgs.msg import TorsoOdometry, TorsoIMU File "/opt/ros/groovy/lib/python2.7/site-packages/nao_msgs/msg/__init__.py", line 29, in <module> from .client import spin, myargv, init_node, \ File "/opt/ros/groovy/lib/python2.7/site-packages/rospy/client.py", line 51, in <module> from ._BodyPoseActionResult import * File "/opt/ros/groovy/lib/python2.7/site-packages/nao_msgs/msg/_BodyPoseActionResult.py", line 1, in <module> import roslib """autogenerated by genpy from nao_msgs/BodyPoseActionResult.msg. Do not edit.""" KeyboardInterrupt File "/opt/ros/groovy/lib/python2.7/site-packages/roslib/__init__.py", line 54, in <module> import roslib.stacks File "/opt/ros/groovy/lib/python2.7/site-packages/roslib/stacks.py", line 46, in <module> import roslib.packages File "/opt/ros/groovy/lib/python2.7/site-packages/roslib/packages.py", line 49, in <module> from catkin.find_in_workspaces import find_in_workspaces as catkin_find File "/opt/ros/groovy/lib/python2.7/site-packages/catkin/find_in_workspaces.py", line 36, in <module> from catkin_pkg.packages import find_packages File "/opt/ros/groovy/lib/python2.7/site-packages/catkin_pkg/packages.py", line 38, in <module> from .package import parse_package, PACKAGE_MANIFEST_FILENAME File "/opt/ros/groovy/lib/python2.7/site-packages/catkin_pkg/package.py", line 48, in <module> class Package(object): KeyboardInterrupt [rosout-1] killing on exit [master] killing on exit shutting down processing monitor... ... shutting down processing monitor complete done

As ... (more)

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2013-08-19 06:43:17 -0600

Miguel S. gravatar image

updated 2013-08-21 08:44:59 -0600

Are you using the version provided with the binaries? Version 0.10 (which can be downloaded from here) shouldn't have that issue.

The version that ships with the NAO v4 binaries hasn't yet been released and the commit that fixes your issue was only merged a few days ago.

We're currently working on a official release. You can either wait for it to be ready (which will hopefully happen soon) try installing version 0.10 (though I suspect v0.10 is not going to mix well with the binary installation) or just run version 0.10 remotely.

Update

The actual issue is that the scripts under nao_driver/src/nao_driver/util don't get installed, if you're in a hurry you can hack it to work by downloading the latest devel version and copying them by hand, eg:

$> git clone -b devel 'https://github.com/miguelsdc/nao_robot.git'
$> cp -r nao_robot/nao_driver/src/nao_driver/util/ /opt/ros/groovy/lib/python2.7/dist-packages/nao_driver/

You may need to use sudo in front of the last command.

edit flag offensive delete link more

Comments

I followed the instructions to install from binaries. I assume it uses that version you specify. Does it have anything to do with the version of NaoQi I am using? It is the 1.14.3

DavidLavy gravatar imageDavidLavy ( 2013-08-19 07:36:09 -0600 )edit

NaoQi 1.14.x should be fine. The version it uses it's *not* 0.10 (it's 0.11). And the bug was fixed on a commit that's not included in your version. I would suggest you wait a bit till we release the proper version, but if you're in a hurry read the updated answer...

Miguel S. gravatar imageMiguel S. ( 2013-08-19 12:51:19 -0600 )edit

Thank you I will try that and let know how it went

DavidLavy gravatar imageDavidLavy ( 2013-08-20 08:21:20 -0600 )edit

Miguel, should I just only copy the util/ folder or the whole src/ folder, which the commando would be: $ cp -r /path/to/temp/dir/nao_robot/nao_driver/src/ src/

DavidLavy gravatar imageDavidLavy ( 2013-08-20 11:17:08 -0600 )edit

Just the util folder (the src folder should be there already!)

Miguel S. gravatar imageMiguel S. ( 2013-08-20 12:09:56 -0600 )edit

Miguel, when I run: Jarvis [0] ~ $ roscd nao_driver/ Jarvis [0] /opt/ros/groovy/share/nao_driver $ ls -a ; I get this output: . .. cmake launch package.xml I don't see any src folder

DavidLavy gravatar imageDavidLavy ( 2013-08-21 05:01:52 -0600 )edit

True, my bad. I forgot the binaries get installed somewhere else... I've updated the instructions.

Miguel S. gravatar imageMiguel S. ( 2013-08-21 08:42:56 -0600 )edit

This is the new error I encountered: Traceback (most recent call last): File "/opt/ros/groovy/lib/nao_driver/nao_controller.py", line 38, in <module> import actionlib ImportError: No module named actionlib I guess there should be another scripts to transfer too

DavidLavy gravatar imageDavidLavy ( 2013-08-21 10:43:37 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-08-19 06:18:43 -0600

Seen: 370 times

Last updated: Aug 21 '13