Ask Your Question
0

Error when installing ROS for Nao robot

asked 2012-07-12 20:54:55 -0600

ryann2k1 gravatar image

updated 2014-04-20 14:09:26 -0600

ngrennan gravatar image

Does anyone manage to install the ros for the nao robot? I am experiencing problems with the installation process. I am installing using the NAO sdk 1.12.3 (geode). For the environment setup (on the website)

export GEODE_CXX=$CTC_DIR/cross/geode/bin/i586-linux-g++
export GEODE_CC=$CTC_DIR/cross/geode/bin/i586-linux-gcc

to

export GEODE_CXX=$CTC_DIR/cross/bin/i686-pc-linux-gnu-g++
export GEODE_CC=$CTC_DIR/cross/bin/i686-pc-linux-gnu-gcc

the compilation errors:

  -- QI_SDK_DIR: /home/anshar/nao/ros/electric/ros/core/roslib/build/sdk
  -- Found PythonInterp: /usr/bin/python2.7 
  [rosbuild] Building package roslib
  [rosbuild] Cached build flags older than manifests; calling rospack to get flags
  [rosbuild] Including /home/anshar/nao/ros/electric/ros_comm/clients/roslisp/cmake/roslisp.cmake
  [rosbuild] Including /home/anshar/nao/ros/electric/ros_comm/clients/rospy/cmake/rospy.cmake
  [rosbuild] Including /home/anshar/nao/ros/electric/ros_comm/clients/cpp/roscpp/cmake/roscpp.cmake
  Traceback (most recent call last):
    File "/home/anshar/nao/ros/electric/ros/bin/rosboost-cfg", line 35, in <module>
      rosboost_cfg.main()
    File "/home/anshar/nao/ros/electric/ros/tools/rosboost_cfg/src/rosboost_cfg/rosboost_cfg.py", line 326, in main
      raise BoostError("Cannot find boost in any of %s"%search_paths(options.sysroot))
  rosboost_cfg.rosboost_cfg.BoostError: "Cannot find boost in any of [('/home/anshar/nao/ros/electric/ros/core/roslib/build/sdk/usr', True), ('/home/anshar/nao/ros/electric/ros/core/roslib/build/sdk/usr/local', True)]"
  CMake Error at /home/anshar/nao/ros/electric/ros/core/rosbuild/public.cmake:881 (message):
    rosboost-cfg --include_dirs failed
  Call Stack (most recent call first):
    CMakeLists.txt:10 (rosbuild_add_boost_directories)


  -- Configuring incomplete, errors occurred!
  make[1]: *** [all] Error 1

Thanks in advance

edit retag flag offensive close merge delete

Comments

What version of ROS are you trying to compile? What command caused that error message?

daniel_maier gravatar imagedaniel_maier ( 2012-07-12 22:42:06 -0600 )edit

im trying to install ros base (ros electric) for Cross-Compiling ROS for the Nao. I install it by referring to http://www.ros.org/wiki/nao/Tutorials/Cross-Compiling . the error generated when compile ROS (Stage 6) with the command:cd ros && make clean && make.

ryann2k1 gravatar imageryann2k1 ( 2012-07-17 15:44:46 -0600 )edit

I managed to compile it.Thanks

ryann2k1 gravatar imageryann2k1 ( 2012-07-31 14:37:31 -0600 )edit
1

Could you post your solution as an answer, so others can benefit from it as well?

AHornung gravatar imageAHornung ( 2012-07-31 22:37:33 -0600 )edit

im directing the ros boost root to directory of ctc/sysroot/usr and also including the ros boost version which is mine is 1.45.0

ryann2k1 gravatar imageryann2k1 ( 2012-08-09 16:25:17 -0600 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2012-08-15 01:54:40 -0600

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Answer from ryan2k1's comment:

Set the ros boost root to the directory of ctc/sysroot/usr and include the Boost version 1.45.0

edit flag offensive delete link more
-1

answered 2013-11-01 21:32:12 -0600

doudoushuixiu gravatar image

i am trying to install the ros in the nao but i have some question, have you successful?

i can't install the nao stacks(version 0.2) in the ros,if you know how to use it,connect me,and thanks~

edit flag offensive delete link more

Comments

What are you trying to achieve? what steps have you followed? To install ROS *on* the robot, please follow these instructions: http://wiki.ros.org/nao/Installation/local

severin gravatar imageseverin ( 2013-11-02 00:18:58 -0600 )edit

in the web :"http://wiki.ros.org/nao/Tutorials/Getting-Started 1.4Installing ROS Stacks" this say:"Add the SVN information as per section 1.2 on installation page:http://www.ros.org/wiki/nao/Installation" but someone tell me that i should use the section 1.1(v0.2) but not 1.2(v0.1)

doudoushuixiu gravatar imagedoudoushuixiu ( 2013-11-02 01:26:49 -0600 )edit

and i don't know clearly how to use catkin to do this

doudoushuixiu gravatar imagedoudoushuixiu ( 2013-11-02 01:27:48 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-07-12 20:54:55 -0600

Seen: 508 times

Last updated: Nov 01 '13