Ask Your Question
4

PrimeSense Failed to set USB interface Error

asked 2013-08-09 16:07:56 -0500

llSourcell gravatar image

updated 2014-01-28 17:17:37 -0500

ngrennan gravatar image

I have an Asus Xtion Camera attached to my computer running ROS Groovy

So far I've installed

  1. Openni_Camera binary ( http://ros.org/wiki/openni_camera )
  2. Openni_launch binary ( http://ros.org/wiki/openni_launch )
  3. Openni SDK ( http://www.openni.org/openni-sdk/ )
  4. PrimeSense Sensor Module for Openni ( https://github.com/PrimeSense/Sensor/tree/unstable )

Everytime I run

roslaunch openni_launch openni.launch

i get this error

    process[camera/depth/metric_rect-8]: started with pid [25941]
process[camera/depth/metric-9]: started with pid [25955]
terminate called after throwing an instance of 'openni_wrapper::OpenNIException'
  what():  unsigned int openni_wrapper::OpenNIDriver::updateDeviceList() @ /tmp/buildd/ros-groovy-openni-camera-1.8.9-0precise-20130724-2255/src/openni_driver.cpp @ 125 : enumerating image nodes failed. Reason: One or more of the following nodes could not be enumerated:

Image: PrimeSense/SensorV2/5.1.2.1: Failed to set USB interface!

process[camera/depth/points-10]: started with pid [25972]
process[camera/register_depth_rgb-11]: started with pid [25973]
process[camera/depth_registered/rectify_depth-12]: started with pid [25974]
[FATAL] [1376100229.602956199]: Service call failed!
[FATAL] [1376100229.605474045]: Service call failed!
[camera_nodelet_manager-1] process has died

I can run samples from the openni sdk outside of ros sometimes like "SimpleViewer". Sometimes it works sometimes it doesn't. I just don't get it. It detects the device but can't set the USB interface...what gives?

edit retag flag offensive close merge delete

Comments

Did you install `/55-primesense-usb.rules` to /etc/udev/rules.d? This file may be found here: https://github.com/PrimeSense/Sensor/blob/unstable/Platform/Linux/Install/55-primesense-usb.rules )

dPackard gravatar imagedPackard ( 2013-08-09 19:07:53 -0500 )edit

dPackard, sorry, it failed 4 times when i tried to post. Fixed.

llSourcell gravatar imagellSourcell ( 2013-08-09 19:13:24 -0500 )edit

How to i install that file to /etc/udev/rules.d ?

llSourcell gravatar imagellSourcell ( 2013-08-09 19:14:56 -0500 )edit
1

If you installed the package via apt-get, tit is probably installed already (just check if the file exists). Otherwise you can create the file manually using your favorite text editor and `sudo`. (e.g. `sudo gvim /etc/udev/rules.d/55-primesense-usb.rules`).

dPackard gravatar imagedPackard ( 2013-08-09 19:16:38 -0500 )edit

Tried that, no luck. I appreciate your help though.

llSourcell gravatar imagellSourcell ( 2013-08-09 19:22:08 -0500 )edit

If that file already exists (or if creating it doesn't help), you might find a solution here: ( http://answers.ros.org/question/55201/using-ros-with-kinect-failed-to-set-usb-interface/ )

dPackard gravatar imagedPackard ( 2013-08-09 19:26:34 -0500 )edit

I went ahead and got a kinect. Still problems, just much less ;)

llSourcell gravatar imagellSourcell ( 2013-08-11 15:55:20 -0500 )edit

Were you able to resolve the issue? I am using a Kinect.

expelliarmus gravatar imageexpelliarmus ( 2014-02-14 18:20:50 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
2

answered 2013-11-11 03:18:08 -0500

Tones gravatar image

I experienced the same problem with the Xtion. It could be resolved by plugging the device into another, non USB3.0 compatible, USB port.

edit flag offensive delete link more
1

answered 2014-03-23 18:35:23 -0500

bit-pirate gravatar image

You might be using one of the newer Xtion cameras, which are not supported by OpenNI 1. For those versions use OpenNI 2, which is already supported by ROS ( http://wiki.ros.org/openni2_camera , http://wiki.ros.org/openni2_launch ).

To verify your version, do

$ lsusb

The older version are listed as

Bus 001 Device 004: ID 1d27:0600

whereas the newer versions are listed as:

Bus 001 Device 004: ID 1d27:0601
edit flag offensive delete link more
0

answered 2014-02-25 03:38:08 -0500

updated 2014-03-23 18:36:06 -0500

bit-pirate gravatar image

I almost get the same error message. If I use the Samples (e.g. NiViewer), my Xtion works well. But when I try to use it with ROS, this appears in the shell:

user@user-HP-Pro3500-Series:~$ roslaunch openni_launch openni.launch
... logging to /home/user/.ros/log/01e75bfc-9e31-11e3-842d-7446a0c4644f/roslaunch-user-HP-Pro3500-Series-2605.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://user-HP-Pro3500-Series:48598/

SUMMARY
========

PARAMETERS
 * /camera/camera_nodelet_manager/num_worker_threads
 * /camera/depth_rectify_depth/interpolation
 * /camera/depth_registered_rectify_depth/interpolation
 * /camera/disparity_depth/max_range
 * /camera/disparity_depth/min_range
 * /camera/disparity_registered_hw/max_range
 * /camera/disparity_registered_hw/min_range
 * /camera/disparity_registered_sw/max_range
 * /camera/disparity_registered_sw/min_range
 * /camera/driver/depth_camera_info_url
 * /camera/driver/depth_frame_id
 * /camera/driver/depth_registration
 * /camera/driver/device_id
 * /camera/driver/rgb_camera_info_url
 * /camera/driver/rgb_frame_id
 * /rosdistro
 * /rosversion

NODES
  /camera/
    camera_nodelet_manager (nodelet/nodelet)
    debayer (nodelet/nodelet)
    depth_metric (nodelet/nodelet)
    depth_metric_rect (nodelet/nodelet)
    depth_points (nodelet/nodelet)
    depth_rectify_depth (nodelet/nodelet)
    depth_registered_rectify_depth (nodelet/nodelet)
    disparity_depth (nodelet/nodelet)
    disparity_registered_hw (nodelet/nodelet)
    disparity_registered_sw (nodelet/nodelet)
    driver (nodelet/nodelet)
    points_xyzrgb_hw_registered (nodelet/nodelet)
    points_xyzrgb_sw_registered (nodelet/nodelet)
    rectify_color (nodelet/nodelet)
    rectify_ir (nodelet/nodelet)
    rectify_mono (nodelet/nodelet)
    register_depth_rgb (nodelet/nodelet)
  /
    camera_base_link (tf/static_transform_publisher)
    camera_base_link1 (tf/static_transform_publisher)
    camera_base_link2 (tf/static_transform_publisher)
    camera_base_link3 (tf/static_transform_publisher)

auto-starting new master
process[master]: started with pid [2619]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 01e75bfc-9e31-11e3-842d-7446a0c4644f
process[rosout-1]: started with pid [2632]
started core service [/rosout]
process[camera/camera_nodelet_manager-2]: started with pid [2635]
process[camera/driver-3]: started with pid [2636]
process[camera/debayer-4]: started with pid [2637]
process[camera/rectify_mono-5]: started with pid [2638]
process[camera/rectify_color-6]: started with pid [2639]
process[camera/rectify_ir-7]: started with pid [2640]
process[camera/depth_rectify_depth-8]: started with pid [2641]
process[camera/depth_metric_rect-9]: started with pid [2642]
process[camera/depth_metric-10]: started with pid [2643]
process[camera/depth_points-11]: started with pid [2644]
process[camera/register_depth_rgb-12]: started with pid [2645]
process[camera/points_xyzrgb_sw_registered-13]: started with pid [2646]
process[camera/depth_registered_rectify_depth-14]: started with pid [2647]
process[camera/points_xyzrgb_hw_registered-15]: started with pid [2648]
process[camera/disparity_depth-16]: started with pid [2649]
process[camera/disparity_registered_sw-17]: started with pid [2650]
process[camera/disparity_registered_hw-18]: started with pid [2738]
process[camera_base_link-19]: started with pid [2791]
process[camera_base_link1-20]: started with pid [2813]
process[camera_base_link2-21]: started with pid [2828]
process[camera_base_link3-22]: started with pid [2867]
[ INFO] [1393341909.783438080]: Initializing nodelet with 4 worker threads.
Warning: USB events thread - failed to set priority. This might cause loss of data...
terminate called after throwing an instance of 'openni_wrapper::OpenNIException'
  what():  unsigned int openni_wrapper::OpenNIDriver::updateDeviceList() @ /tmp/buildd/ros-hydro-openni-camera-1.9.2-0precise-20140130-2209/src/openni_driver.cpp @ 125 : enumerating image nodes failed. Reason: One or more of the following nodes could not be enumerated:

**Image: PrimeSense/SensorV2/5.1.4.0: Failed to set USB interface!**

[camera/camera_nodelet_manager-2] process has died [pid 2635, exit code -6, cmd /opt/ros/hydro/lib/nodelet/nodelet manager __name:=camera_nodelet_manager __log:=/home/user/.ros/log/01e75bfc-9e31-11e3-842d-7446a0c4644f/camera-camera_nodelet_manager-2.log].
log file: /home/user/.ros/log/01e75bfc-9e31-11e3-842d-7446a0c4644f/camera-camera_nodelet_manager-2*.log
[FATAL] [1393341923.771342381]: Service call failed!
[FATAL] [1393341923.771561793]: Service call failed!
[FATAL] [1393341923.771767482]: Service call failed!
[FATAL] [1393341923.771772273]: Service call failed!
[FATAL] [1393341923.772084463 ...
(more)
edit flag offensive delete link more

Comments

I am having this same problem.

Dave Coleman gravatar imageDave Coleman ( 2014-10-24 01:22:11 -0500 )edit
1

@Dave Coleman What camera are you using (version, ID)? We probably have all flavours of the Primesense devices here in the lab and got them working one way or the other.

bit-pirate gravatar imagebit-pirate ( 2014-11-29 04:27:30 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-08-09 16:07:56 -0500

Seen: 13,723 times

Last updated: Mar 23 '14