Ask Your Question
0

erratic_navigation error before costmap

asked 2013-08-06 02:35:37 -0600

DIDI gravatar image

updated 2013-08-06 21:03:31 -0600

I have a problem with the navigation stack. I use Fuerte and tried to run a simulation with the erratic robot:

roslaunch erratic_navigation move_base_local.launch

….

NODES
  /move_base_node/local_costmap/
    voxel_grid_throttle (topic_tools/throttle)
  /
    move_base_node (move_base/move_base)

auto-starting new master
process[master]: started with pid [25088]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 27570100-fe93-11e2-bc47-002622350f36
process[rosout-1]: started with pid [25101]
started core service [/rosout]
process[move_base_node/local_costmap/voxel_grid_throttle-2]: started with pid [25113]
process[move_base_node-3]: started with pid [25127]
[ INFO] [1375791876.551792597]: Subscribed to Topics: base_scan base_scan_marking
[ WARN] [1375791881.653678739]: Waiting on transform from /base_footprint to /odom to become available before running costmap, tf error:

and with: roslaunch erratic_navigation_apps erratic_2dnav.launch ...

NODES
  /move_base_node/local_costmap/
    voxel_grid_throttle (topic_tools/throttle)
  /
    amcl (amcl/amcl)
    move_base_node (move_base/move_base)
    voxel_visualizer (costmap_2d/costmap_2d_markers)

auto-starting new master
process[master]: started with pid [25999]
ROS_MASTER_URI=http://localhost:11311

setting /run_id to 6caa4438-fe93-11e2-9666-002622350f36
process[rosout-1]: started with pid [26012]
started core service [/rosout]
process[amcl-2]: started with pid [26024]
process[move_base_node/local_costmap/voxel_grid_throttle-3]: started with pid [26081]
[ INFO] [1375791992.682028086]: Requesting the map...
[ WARN] [1375791992.683369458]: Request for map failed; trying again...
process[move_base_node-4]: started with pid [26130]
process[voxel_visualizer-5]: started with pid [26145]
[ INFO] [1375791993.099960562]: Subscribed to Topics: base_scan base_scan_marking
[ INFO] [1375791993.122128742]: Requesting the map...

[ INFO] [1375791993.124315334]: Still waiting on map...

[ WARN] [1375791993.184716658]: Request for map failed; trying again...

I guess they are connected, but I don't know where the problem is. Just installed it and tried to launch it and make the first steps. Any ideas?

edit retag flag offensive close merge delete

Comments

This works, for whatever the reason: roslaunch erratic_navigation_apps demo_2dnav_slam.launch

DIDI gravatar imageDIDI ( 2013-08-06 02:54:47 -0600 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2013-08-07 01:46:34 -0600

DIDI gravatar image

I have to start first the Gazebo simulator and set up a robot model like this:

roslaunch gazebo_worlds empty_world.launch
roslaunch erratic_description erratic_mobile_base.launch

And then:

roslaunch erratic_description erratic_mobile_base.launch
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-08-06 02:35:37 -0600

Seen: 157 times

Last updated: Aug 07 '13