Scan topic is not published [closed]

asked 2013-07-23 12:32:26 -0600

salime gravatar image

updated 2016-10-24 09:04:23 -0600

ngrennan gravatar image

I am working with slam_gmapping, and When I launch the pointcloud to laser scan with this file, I do the following steps:

<launch>
  <!-- kinect nodes -->
  <include file="$(find openni_camera)/launch/openni_node.launch"/>

  <!-- openni_manager -->
  <node pkg="nodelet" type="nodelet" name="openni_manager" output="screen" respawn="true" args="manager"/>

  <!-- throttling -->
  <node pkg="nodelet" type="nodelet" name="pointcloud_throttle" args="load pointcloud_to_laserscan/CloudThrottle openni_manager">
    <param name="max_rate" value="2"/>
    <remap from="cloud_in" to="/camera/depth/points"/>
    <remap from="cloud_out" to="cloud_throttled"/>
  </node>

  <!-- fake laser -->
  <node pkg="nodelet" type="nodelet" name="kinect_laser" args="load pointcloud_to_laserscan/CloudToScan openni_manager">
    <param name="output_frame_id" value="/openni_depth_frame"/>
    <remap from="cloud" to="cloud_throttled"/>
  </node>
</launch>

1) After launch the file I open rviz , I set the fixed name to /openni_depth_frame and add a Laser Scan Display.

I followed this tutorial http://answers.ros.org/question/10606/problem-launching-pointcloud-to-laserscan/, and it says that I should see the /scan topic, but I am not able to see it.

How can I solve this?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2014-10-27 19:32:22.403969