Ask Your Question
0

rosbag will not create bag file

asked 2013-07-23 06:01:34 -0500

Robocop87 gravatar image

Hi everyone!

I am running rosbag from a launch file, and the terminal says the process starts cleanly. After ending the process however, I cannot find the bag file and all my data is lost. Here is the launch file:

<launch>
    <include file="$(find AK_Loc)/launch/ak_localize.launch" />

    <node name="Command_Predictor" pkg="cmd_predictor" type="TL_Predictor.py" />

    <node pkg="rosbag" type="record" name="cmds" args="-o act_and_pred_cmds /actCmds /cmdPreds" />

</launch>

and I am running ROS Groovy on Ubuntu 12.04.

Any ideas? Thanks in advance!

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
2

answered 2013-07-23 13:37:13 -0500

Thomas D gravatar image

updated 2013-07-24 04:16:36 -0500

Try find ~/.ros -name \*.bag.

edit flag offensive delete link more
0

answered 2013-07-23 07:15:57 -0500

allenh1 gravatar image

updated 2013-07-23 07:18:36 -0500

Procópio gravatar image

It needs to be a capital "O". You have the lower case "o".

<launch>
    <include file="$(find AK_Loc)/launch/ak_localize.launch" />

    <node name="Command_Predictor" pkg="cmd_predictor" type="TL_Predictor.py" />

    <node pkg="rosbag" type="record" name="cmds" args="-O act_and_pred_cmds /actCmds /cmdPreds" />

</launch>
edit flag offensive delete link more

Comments

Also, look in your ~/.ros directory for bag files when you start recording from a launch file.

Thomas D gravatar image Thomas D  ( 2013-07-23 08:03:30 -0500 )edit

@allenh1 Thank you for your answer! The capital O is for when you are specifying the whole path, while the lowercase o is for adding text to the beginning of the standard filename. Also I tried it without the o completely and it still didn't make a file.

Robocop87 gravatar image Robocop87  ( 2013-07-23 10:09:46 -0500 )edit

@Thomas D, I used the "locate" command line tool to search for all .bag files. While some appeared in the /.ros directory, they were not the ones I was looking for. Thank you for your suggestion though!

Robocop87 gravatar image Robocop87  ( 2013-07-23 10:10:59 -0500 )edit

It would appear that worked! Im not sure why that worked but not locate though. If you post an answer I will select it as the accepted solution, thanks Thomas!

Robocop87 gravatar image Robocop87  ( 2013-07-24 02:08:53 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-07-23 06:01:34 -0500

Seen: 945 times

Last updated: Jul 24 '13