ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

How to install ROS on pcDuino ? (Lubuntu 12.04 ARM)

asked 2013-07-20 13:15:04 -0500

mozcelikors gravatar image

updated 2014-01-28 17:17:21 -0500

ngrennan gravatar image


Last week, I've purchased a pcDuino. It comes with Lubuntu v12.04. In order to download, compile, and install ROS; I'm following the documentation of Pandaboard from this link the Pandaboard source installation

However, when I try to install the remaining dependencies with the

 sudo rosdep install --from-paths src --ignore-src --rosdistro groovy -y

command. It gives an error that says "Could Not Detect OS: tried windows,ubuntu,...." I don't know if it's because of the reason that pcDuino uses Lubuntu. I've searched about this error but there is no certain answer that I've understood.

It would be appreciated if anybody can help me solve this problem or tell me just an easier way to install ROS on pcDuino?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2013-07-21 01:21:08 -0500

gvdhoorn gravatar image

I'm not sure Lubuntu is already supported (as in: rosdep knows about it), but just to get you going: you can use the environment variable ROS_OS_OVERRIDE to force rosdep to use the rules for a particular OS. Just make sure you set it to the right value for your OS. See EnvironmentVariables#ROS_OS_OVERRIDE on the wiki for more information.

edit flag offensive delete link more


I will try that and get back to you. I suppose I should write ubuntu:12.04 correct?

mozcelikors gravatar image mozcelikors  ( 2013-07-21 21:18:16 -0500 )edit

answered 2013-07-22 05:12:50 -0500

mozcelikors gravatar image

Linaro is not currently supported by ROS, but you can install its base using Ubuntu ARM with simple modifications following the source here: Since I'm not able to provide link just google "yuanboshe pcduino ros groovy" and follow instructions. When installation is completed, you have to add the line

export ROS_OS_OVERRIDE=ubuntu:12.04

to the ~/.bashrc file to use rospack, roscd, and other stuff correctly. It worked for me. (I was able to make publisher/subscriber demonstration example)

edit flag offensive delete link more

Question Tools



Asked: 2013-07-20 13:15:04 -0500

Seen: 1,934 times

Last updated: Jul 22 '13