Ask Your Question
0

Trying to install dynamixel_controllers in Fuerte getting error

asked 2013-07-19 06:57:00 -0600

joe.s gravatar image

I'm attempting to install the dynamixel_controllers package in Fuerte. This is a fresh installation of Fuerte on a 12.04 machine. I'm receiving this error after downloading the package and typing "rosmake dynamixel_controllers" I receive this error:
[ rosmake ] rosmake starting...
[ rosmake ] Packages requested are: ['dynamixel_controllers']
[ rosmake ] Logging to directory /home/joe/.ros/rosmake/rosmake_output-20130719-115348 [ rosmake ] Expanded args ['dynamixel_controllers'] to: ['dynamixel_controllers'] [rosmake-0] Starting >>> roslang [ make ]
[rosmake-1] Starting >>> rostest [ make ]
[rosmake-0] Finished <<< roslang No Makefile in package roslang
[rosmake-2] Starting >>> actionlib_msgs [ make ]
[rosmake-1] Finished <<< rostest No Makefile in package rostest
[rosmake-0] Starting >>> rospy [ make ]
[rosmake-3] Starting >>> roscpp [ make ]
[rosmake-2] Finished <<< actionlib_msgs No Makefile in package actionlib_msgs
[rosmake-4] Starting >>> diagnostic_msgs [ make ]
[rosmake-1] Starting >>> std_msgs [ make ]
[rosmake-2] Starting >>> trajectory_msgs [ make ]
[rosmake-0] Finished <<< rospy No Makefile in package rospy
[rosmake-0] Starting >>> dynamixel_msgs [ make ]
[rosmake-4] Finished <<< diagnostic_msgs No Makefile in package diagnostic_msgs [rosmake-5] Starting >>> control_msgs [ make ]
[rosmake-3] Finished <<< roscpp No Makefile in package roscpp
[rosmake-3] Starting >>> actionlib [ make ]
[rosmake-1] Finished <<< std_msgs No Makefile in package std_msgs
[rosmake-4] Starting >>> dynamixel_driver [ make ]
[rosmake-2] Finished <<< trajectory_msgs No Makefile in package trajectory_msgs [rosmake-3] Finished <<< actionlib No Makefile in package actionlib
[rosmake-5] Finished <<< control_msgs ROS_NOBUILD in package control_msgs No Makefile in package control_msgs [rosmake-4] Finished <<< dynamixel_driver [PASS] [ 0.57 seconds ]
[rosmake-0] Finished <<< dynamixel_msgs [PASS] [ 1.08 seconds ]
[rosmake-0] Starting >>> dynamixel_controllers [ make ]
[ rosmake ] Last 40 linesnamixel_controllers: 3.6... [ 1 Active 12/13 Complete ] {------------------------------------------------------------------------------- valid_packages = valid_packages + rospack.get_depends(package_context, implicit=True) TypeError: can only concatenate list (not "set") to list make[3]: *** [../srv_gen/lisp/StartController.lisp] Error 1 make[3]: *** [../srv_gen/lisp/SetTorqueLimit.lisp] Error 1 Traceback (most recent call last): File "/opt/ros/fuerte/share/roslisp/rosbuild/scripts/genmsg_lisp.py", line 873, in <module> generate_srv(sys.argv[1]) File "/opt/ros/fuerte/share/roslisp/rosbuild/scripts/genmsg_lisp.py", line 822, in generate_srv write_srv_component(s, spec.request, spec) File "/opt/ros/fuerte/share/roslisp/rosbuild/scripts/genmsg_lisp.py", line 697, in write_srv_component write_md5sum(s, spec, parent) File "/opt/ros/fuerte/share/roslisp/rosbuild/scripts/genmsg_lisp.py", line 596, in write_md5sum compute_files=False) File "/opt/ros/fuerte/lib/python2.7/dist-packages/roslib/gentools.py", line 314, in get_dependencies _add_msgs_depends(rospack, spec.response, deps, package)
File "/opt/ros/fuerte/lib/python2.7/dist-packages/roslib/gentools.py", line 75, in _add_msgs_depends valid_packages = valid_packages + rospack.get_depends(package_context, implicit=True) TypeError: can only concatenate list (not "set") to list Traceback (most recent call last): File "/opt/ros/fuerte/share/roslisp/rosbuild/scripts/genmsg_lisp.py", line 873, in <module> generate_srv(sys.argv[1]) File "/opt/ros/fuerte/share/roslisp/rosbuild/scripts/genmsg_lisp.py", line 822, in generate_srv write_srv_component(s, spec.request, spec) File "/opt/ros/fuerte/share/roslisp/rosbuild/scripts/genmsg_lisp.py", line 697, in write_srv_component write_md5sum(s, spec, parent) File "/opt/ros/fuerte/share/roslisp/rosbuild/scripts/genmsg_lisp.py", line 596, in write_md5sum compute_files=False) File "/opt/ros/fuerte/lib/python2.7/dist-packages/roslib/gentools.py", line 314, in get_dependencies _add_msgs_depends(rospack, spec.response, deps, package)
File "/opt/ros/fuerte/lib/python2.7/dist-packages/roslib/gentools.py", line 75, in _add_msgs_depends valid_packages = valid_packages + rospack.get_depends(package_context ...
(more)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-07-21 04:39:26 -0600

arebgun gravatar image

updated 2013-07-21 15:07:18 -0600

I see that you are using Ubuntu 12.04, there should be packages available for dynamixel_motor stack on Fuerte. Any reason you are trying to compile from source?

edit flag offensive delete link more

Comments

When I did a search using the ROS search bar, that was the package that came up. I did not see the dynamixel_motor stack until after troubleshooting. I have since found it but haven't confirmed that things are working properly yet. I will post back once I have made sure everything is working properly.

joe.s gravatar imagejoe.s ( 2013-07-22 04:45:25 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-07-19 06:57:00 -0600

Seen: 262 times

Last updated: Jul 21 '13