ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
0

Error with catkin_make when building package beginner_tutorials

asked 2013-07-05 08:14:04 -0500

Praseen gravatar image

updated 2013-07-07 08:47:35 -0500

joq gravatar image

Hi, I have installed a ROS groovy from source on Ubuntu 12.04 and working on the basic tutorial to get familiarised with ROS. As part of creating a message and service for the beginner_tutorials package mentioned in the basic tutorial I am getting the following error when I run catkin_make, given below is the error. Please let me know how to proceed.

Base path: /home/neo/ros_catkin_ws
Source space: /home/neo/ros_catkin_ws/src
Build space: /home/neo/ros_catkin_ws/build
Devel space: /home/neo/ros_catkin_ws/devel
Install space: /home/neo/ros_catkin_ws/install
WARNING: Metapackage "vision_opencv" must buildtool_depend on catkin.
WARNING: Metapackage "image_transport_plugins" must buildtool_depend on catkin.
WARNING: Metapackage "geometry" must buildtool_depend on catkin.
WARNING: Metapackage "perception_pcl" must buildtool_depend on catkin.
WARNING: Metapackage "image_common" must buildtool_depend on catkin.
WARNING: Metapackage "diagnostics" must buildtool_depend on catkin.
WARNING: Metapackage "geometry_experimental" must buildtool_depend on catkin.
WARNING: Metapackage "nodelet_core" must buildtool_depend on catkin.
####
#### Running command: "cmake /home/neo/ros_catkin_ws/src -DCATKIN_DEVEL_PREFIX=/home/neo/ros_catkin_ws/devel -DCMAKE_INSTALL_PREFIX=/home/neo/ros_catkin_ws/install" in "/home/neo/ros_catkin_ws/build"
####
-- Using CATKIN_DEVEL_PREFIX: /home/neo/ros_catkin_ws/devel
-- Using CMAKE_PREFIX_PATH: /home/neo/ros_catkin_ws/install_isolated
-- This workspace overlays: /home/neo/ros_catkin_ws/install_isolated
-- Found gtest sources under '/usr/src/gtest': gtests will be built
-- Using CATKIN_TEST_RESULTS_DIR: /home/neo/ros_catkin_ws/build/test_results
-- catkin 0.5.66
-- BUILD_SHARED_LIBS is on
WARNING: Metapackage "vision_opencv" must buildtool_depend on catkin.
WARNING: Metapackage "image_transport_plugins" must buildtool_depend on catkin.
WARNING: Metapackage "geometry" must buildtool_depend on catkin.
WARNING: Metapackage "perception_pcl" must buildtool_depend on catkin.
WARNING: Metapackage "image_common" must buildtool_depend on catkin.
WARNING: Metapackage "diagnostics" must buildtool_depend on catkin.
WARNING: Metapackage "geometry_experimental" must buildtool_depend on catkin.
WARNING: Metapackage "nodelet_core" must buildtool_depend on catkin.
-- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-- ~~  traversing 181 packages in topological order:
-- ~~  - bfl (plain cmake)
-- ~~  - angles
-- ~~  - bond_core (metapackage)
-- ~~  - camera_calibration
-- ~~  - common_msgs (metapackage)
-- ~~  - console_bridge
-- ~~  - class_loader
-- ~~  - convex_decomposition
-- ~~  - cpp_common
-- ~~  - diagnostics (metapackage)
WARNING: The metapackage 'diagnostics' has no CMakeLists.txt. Please add one to the package source. You can use the following file: /home/neo/ros_catkin_ws/build/catkin_generated/metapackages/diagnostics/CMakeLists.txt
-- ~~  - driver_common (metapackage)
-- ~~  - flann (plain cmake)
-- ~~  - genmsg
-- ~~  - gencpp
-- ~~  - genlisp
-- ~~  - genpy
-- ~~  - geometry (metapackage)
WARNING: The metapackage 'geometry' has no CMakeLists.txt. Please add one to the package source. You can use the following file: /home/neo/ros_catkin_ws/build/catkin_generated/metapackages/geometry/CMakeLists.txt
-- ~~  - geometry_experimental (metapackage)
WARNING: The metapackage 'geometry_experimental' has no CMakeLists.txt. Please add one to the package source. You can use the following file: /home/neo/ros_catkin_ws/build/catkin_generated/metapackages/geometry_experimental/CMakeLists.txt
-- ~~  - image_common (metapackage)
WARNING: The metapackage 'image_common' has no CMakeLists.txt. Please add one to the package source. You can use the following file: /home/neo/ros_catkin_ws/build/catkin_generated/metapackages/image_common/CMakeLists.txt
-- ~~  - image_pipeline (metapackage)
-- ~~  - image_transport_plugins (metapackage)
WARNING: The metapackage 'image_transport_plugins' has no CMakeLists.txt. Please add one to the package source. You can use the following file: /home/neo/ros_catkin_ws/build/catkin_generated/metapackages/image_transport_plugins/CMakeLists.txt
-- ~~  - ivcon
-- ~~  - message_generation
-- ~~  - message_runtime
-- ~~  - mk
-- ~~  - nodelet_core (metapackage)
WARNING: The metapackage 'nodelet_core' has no CMakeLists.txt. Please add one to the package source. You can use the following file: /home/neo/ros_catkin_ws/build/catkin_generated/metapackages/nodelet_core/CMakeLists.txt
-- ~~  - opencv2 (plain cmake)
-- ~~  - orocos_kdl ...
(more)
edit retag flag offensive close merge delete

Comments

1

Ignore the warnings about metapackages. Do you have non-catkin packages in your workspace?

joq gravatar imagejoq ( 2013-07-07 08:50:30 -0500 )edit

Hi joq, Thanks a ton for your response. Well I have two work spaces, one for catkin packages and the other for non-catkin packages. This file structure was created by Groovy itself. Please let me know how to proceed.

Praseen gravatar imagePraseen ( 2013-07-07 11:58:46 -0500 )edit

The wiki needs to be updated please. The command catkin_make_isolated works, but it builds all the packages in the catkin workspace and can take some time. Thanks a lot all, especially joq, for the response and support

Praseen gravatar imagePraseen ( 2013-07-07 13:53:33 -0500 )edit
1

If your catkin workspace is properly separated from your rosbuild workspace, catkin_make should work, you should not need catkin_make_isolated.

joq gravatar imagejoq ( 2013-07-07 17:12:34 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-07-08 09:00:40 -0500

William gravatar image

updated 2013-07-08 10:43:32 -0500

This is the relevant error:

CMake Error at catkin/cmake/catkin_workspace.cmake:88 (message):
  This workspace contains non-catkin packages in it, and catkin cannot build
  a non-homogeneous workspace without isolation.

You need to use catkin_make_isolated --install.

Also, since you are on 12.04, you can just install the debians, are you installing from source for any particular reason?

The from source install instructions tell you to use catkin_make_isolated:

http://www.ros.org/wiki/groovy/Installation/Source#line-95

edit flag offensive delete link more

Comments

Hi William, thank you for your response. I am installing from source so that I will be able to modify the existing source and I can hopefully use this experience to get this working on the Raspberry Pi board on which I am working.

Praseen gravatar imagePraseen ( 2013-07-10 06:29:21 -0500 )edit

@Praseen, That sounds good, I just wanted to make sure you knew that the debians were available.

William gravatar imageWilliam ( 2013-07-10 07:20:27 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-07-05 08:14:04 -0500

Seen: 5,534 times

Last updated: Jul 08 '13