Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

This is the relevant error:

CMake Error at catkin/cmake/catkin_workspace.cmake:88 (message):
  This workspace contains non-catkin packages in it, and catkin cannot build
  a non-homogeneous workspace without isolation.

You need to use catkin_make_isolated --install.

Also, since you are on 12.04, you can just install the debians, are you installing from source for any particular reason. The from source install instructions tell you to use catkin_make_isolated:

http://www.ros.org/wiki/groovy/Installation/Source#line-95

This is the relevant error:

CMake Error at catkin/cmake/catkin_workspace.cmake:88 (message):
  This workspace contains non-catkin packages in it, and catkin cannot build
  a non-homogeneous workspace without isolation.

You need to use catkin_make_isolated --install.

Also, since you are on 12.04, you can just install the debians, are you installing from source for any particular reason. reason?

The from source install instructions tell you to use catkin_make_isolated:

http://www.ros.org/wiki/groovy/Installation/Source#line-95