Ask Your Question
0

unable to install catkin on noetic, ubuntu 20.04 with kubuntu

asked 2022-01-22 19:43:00 -0500

MiguelMTS gravatar image

updated 2022-01-25 06:28:04 -0500

gvdhoorn gravatar image

Suposing that catkin was automatically installed with noetic, when I used catkin_make, the command was not found. I tried to install catkin but I received :

The following packages have unset dependencies:
    catkin: Depends: python3-catkin-pkg (>= 0.4.14-2)but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

The package python3-catkin-pkg (0.4.24-100) is really installed.

What can I do?

edit retag flag offensive close merge delete

Comments

Pls make sure not to forget to source.

Also check prior answers: https://answers.ros.org/question/3417...

osilva gravatar image osilva  ( 2022-01-24 07:28:00 -0500 )edit

I did not forget to source. I also had used the same repositories as in question 3417.and that was the result.

MiguelMTS gravatar image MiguelMTS  ( 2022-01-24 14:00:47 -0500 )edit

Have you tried installing python catkin tools?

sudo apt install python3-catkin-tools
parmex gravatar image parmex  ( 2022-01-25 02:51:50 -0500 )edit

Yes, I did too, and finally arrived to the impossibility aforementioned.

I have repeated the process from the beginning several times and in different ways and always gat the same final result.

MiguelMTS gravatar image MiguelMTS  ( 2022-01-25 05:48:07 -0500 )edit

It could be a Kubuntu issue not necessarily ROS. Ubuntu is the recommended OS

osilva gravatar image osilva  ( 2022-01-25 06:24:52 -0500 )edit

What is the output of:

  1. lsb_release -a
  2. dpkg -l | grep catkin
  3. after sourceing: which catkin_make

And what does:

I did not forget to source

mean exactly?

Unless you've setup to auto-source (via your .bashrc fi), you'll have to source in every terminal manually. A single time won't work for future terminals.


Edit, just noticed:

I tried to install catkin [..]

how? Which command did you use, exactly?

Note that catkin is not the same package as python3-catkin-pkg.

And the latter is not the package which provides the catkin_make command. That would be ros-noetic-catkin. Are you perhaps mixing in wiki/UpstreamPackages?

gvdhoorn gravatar image gvdhoorn  ( 2022-01-25 06:27:20 -0500 )edit

Yes, I included source via .bashrc. I used ros-noetic-catkin

The result for dpkg is:

      ii              python3-catkin               0.8.0-1ubuntu2                 all
      ii              python3-catkin-pkg        0.4.16-1                            all
MiguelMTS gravatar image MiguelMTS  ( 2022-01-25 17:36:30 -0500 )edit

please answer all questions, and be precise.

We cannot help you otherwise.

gvdhoorn gravatar image gvdhoorn  ( 2022-01-26 02:48:56 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2022-01-26 11:46:03 -0500

MiguelMTS gravatar image

Thank you all for your help. Finally I got everything installed correctly. Bu I don't know yet where was the failure. For sure, as I had included the source into the .bashrc file as a first step, in my first reboot it didn't recognized the path of the source because ths noetic directory did not exist yet. From so on, that source was not registered. Thank you very much indeed and I apologize the time you have dedicated.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2022-01-22 19:43:00 -0500

Seen: 82 times

Last updated: Jan 25