Ask Your Question
0

OpenNI and RGBDSLAM Launch Files

asked 2013-06-10 13:53:00 -0600

rosslam gravatar image

updated 2016-10-24 08:59:41 -0600

ngrennan gravatar image

I'm having a issue with the ROS RGBDSLAM installation in Fuerte. Whenever I run "roslaunch rgbdslam kinect+rgbdslam.launch" an empty RGBDSLAM GUI pops up. The terminal shows the error:

[ INFO] [1370907710.759761259]: No devices connected.... waiting for devices to be connected

even though I have the Kinect Xbox 360 connected and LibFreenect works fine. What am I doing wrong?

It appears to be an issue with OpenNI in particular, since when I run "roslaunch openni_launch openni.launch" the same error occurs.

Glancing at the source code in openni.launch and device.launch (in home/ros_workspace/rgbdslam_freiburg/rgbdslam/launch), I noticed that "depth_registered.launch" and "depth.launch" are referenced, but do not exist. Maybe that's the issue?

Ex, see code section:

<!-- Unregistered depth processing --> <include file="$(find openni_launch)/launch/includes/depth.launch"
       ns="$(arg depth)">
    <arg name="manager" value="$(arg manager)" />
    <arg name="bond" value="$(arg bond)" />   </include>

  <!-- Depth-to-RGB registration and processing -->   <include file="$(find openni_launch)/launch/includes/depth_registered.launch">
    <arg name="manager" value="$(arg manager)" />
    <arg name="rgb" value="$(arg rgb)" />
    <arg name="depth" value="$(arg depth)" />
    <arg name="depth_registered" value="$(arg depth_registered)" />
    <arg name="bond" value="$(arg bond)" />   </include>

Thank you!

edit retag flag offensive close merge delete

Comments

Your device is not found. I have seen reports that some drivers have problems with newer versions of the Xtion pro, maybe that holds true for your Kinect? Otherwise, have you tried a different USB port, preferrably a USB 2.0 port?

Felix Endres gravatar imageFelix Endres ( 2013-06-11 05:49:31 -0600 )edit

This issue arises for Asus xtion pro live devices and new version of microsoft kinect "kinect 4 windows"

sai gravatar imagesai ( 2013-06-11 07:46:56 -0600 )edit

If you have a Turtlebot and if your camera is draining power from your robot, make sure it's set to full mode on the dashboard. I have to do that every time I want to use openni + Kinect.

Zayin gravatar imageZayin ( 2013-06-12 10:39:42 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-06-13 19:44:38 -0600

sai gravatar image

updated 2013-06-13 19:46:36 -0600

Hi,

You can find the installation steps to get the new kinect 4 windows working from these links

http://www.20papercups.net/programming/kinect-on-ubuntu-with-openni/

https://groups.google.com/forum/?fromgroups=#!msg/openni-dev/h0F6kYCNigs/BR6iqqFhSJ8J

http://mitchtech.net/ubuntu-kinect-openni-primesense/

Before these installation,

remove the old library files from ubuntu software center searching for libopenni.

after installation,

dont do rosdep install openni_launch.

directly do rosmake openni_launch and it should work.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-06-10 13:53:00 -0600

Seen: 912 times

Last updated: Jun 13 '13