Ask Your Question
0

Sketchup to urdf file not found

asked 2013-06-03 23:28:47 -0600

updated 2013-06-05 20:25:35 -0600

Hi guys,

I'm trying to import my robotmodel on rviz but when I change the urdf file from

<cylinder length="0.6" radius="0.2"/>

to a mesh (created by sketchup) like

<mesh filename="package://robo01.dae"/>

when i run rviz the shell tell me

[ERROR] [1370333859.322282991]: Could not load resource [package://robo01.dae]: Unable to open file "package://robo01.dae". following this post https://code.ros.org/gf/project/ros/mailman/?_forum_action=ForumMessageBrowse&thread_id=56835&action=ListThreads&mailman_id=20

i try

ls rospack find urdf_tutorial/robo01.dae

and it tell me that the file is in correct place (??).

Could someone tell me what I'm doing wrong?

thanks a lot guys for your answer

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-06-07 03:23:53 -0600

Pi Robot gravatar image

updated 2013-06-07 03:24:55 -0600

Hi @danielq,

You need to specify the actual package name and subdirectory (if any) in your URL. So try this:

<mesh filename="package://urdf_tutorial/robo01.dae"/>

If your model was in a subdirectory of the urdf_tutorial package called "meshes" (for example), you would use:

<mesh filename="package://urdf_tutorial/meshes/robo01.dae"/>

--patrick

edit flag offensive delete link more

Comments

thanks Patrick for the answer. It was soo simple soo it works.

danielq gravatar imagedanielq ( 2013-06-07 07:13:35 -0600 )edit

Hi @danielq. Glad that did the trick. Please mark the answer as "correct" by clicking the checkmark above.

Pi Robot gravatar imagePi Robot ( 2013-06-12 03:28:00 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-06-03 23:28:47 -0600

Seen: 670 times

Last updated: Jun 07 '13