Ask Your Question

Revision history [back]

Sketchup to urdf file not found

Hi guys,

I'm trying to import my robotmodel on rviz but when I change the urdf file from

<cylinder length="0.6" radius="0.2"/>

to a mesh (created by sketchup) like

<mesh filename="package://robo01.dae"/>

when i run rviz the shell tell me

[ERROR] [1370333859.322282991]: Could not load resource [package://robo01.dae]: Unable to open file "package://robo01.dae". following this post https://code.ros.org/gf/project/ros/mailman/?_forum_action=ForumMessageBrowse&thread_id=56835&action=ListThreads&mailman_id=20

i try

ls rospack find urdf_tutorial/robo01.dae

and it tell me that the file is in correct place (??).

Could someone tell me what I'm doing wrong?

thanks a lot guys for your answer

Sketchup to urdf file not found

Hi guys,

I'm trying to import my robotmodel on rviz but when I change the urdf file from

<cylinder length="0.6" radius="0.2"/>

to a mesh (created by sketchup) like

<mesh filename="package://robo01.dae"/>

when i run rviz the shell tell me

[ERROR] [1370333859.322282991]: Could not load resource [package://robo01.dae]: Unable to open file "package://robo01.dae". following this post https://code.ros.org/gf/project/ros/mailman/?_forum_action=ForumMessageBrowse&thread_id=56835&action=ListThreads&mailman_id=20

i try

ls rospack find urdf_tutorial/robo01.dae

and it tell me that the file is in correct place (??).

Could someone tell me what I'm doing wrong?

thanks a lot guys for your answer

Sketchup to urdf file not found

Hi guys,

I'm trying to import my robotmodel on rviz but when I change the urdf file from

<cylinder length="0.6" radius="0.2"/>

to a mesh (created by sketchup) like

<mesh filename="package://robo01.dae"/>

when i run rviz the shell tell me

[ERROR] [1370333859.322282991]: Could not load resource [package://robo01.dae]: Unable to open file "package://robo01.dae". following this post https://code.ros.org/gf/project/ros/mailman/?_forum_action=ForumMessageBrowse&thread_id=56835&action=ListThreads&mailman_id=20

i try

ls rospack find urdf_tutorial/robo01.dae

and it tell me that the file is in correct place (??).

Could someone tell me what I'm doing wrong?

thanks a lot guys for your answer