Ask Your Question
0

How to install Groovy on Ubuntu 13.04

asked 2013-05-30 22:50:47 -0500

Albert K gravatar image

I want to test Morse simulator recently. Since Morse only support Ubuntu 13.04 or later, I wonder if there is any approach to install Groovy on Ubuntu 13.04? Thanks

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
1

answered 2013-05-31 05:37:00 -0500

joq gravatar image

updated 2013-05-31 05:38:53 -0500

A cleaner option is probably building what you need from source.

That will be more work for you, but is more likely to produce a reliable result than installing binaries that were built for a different Ubuntu version.

edit flag offensive delete link more
1

answered 2013-05-31 08:10:52 -0500

updated 2013-05-31 08:34:48 -0500

This doesn't directly answer the question, but MORSE does not just support Ubuntu 13.04. I'm currently running it on several 12.04 systems. As long as you have cmake, Python 3.2, and Blender >2.62 MORSE should run. See the installation instructions at: http://www.openrobots.org/morse/doc/latest/user/installation.html

EDIT: I think the confusion might be in the fact that Morse 1.0 is only available in the package manager for Ubuntu 13.04 and newer. Morse 0.6 can be installed on previous versions using the package manager. MORSE 1.0 can be installed (very easily) from source on older versions. Things might have changed with 1.0, but on previous versions the version in the package manager did not support ROS. You had to build from source to enable ROS middleware support. The MORSE mailing list would be a better place to get an answer to that question.

edit flag offensive delete link more

Comments

Back-porting MORSE to a system on which Groovy is officially supported, may well be the easiest solution.

joq gravatar imagejoq ( 2013-05-31 08:15:17 -0500 )edit
1

answered 2013-05-31 03:46:39 -0500

allenh1 gravatar image

You can install Groovy by using the same repository quantal uses; however, I caution you with this. I did it, but it works only after doing some things first.

To begin, you must install qt4, NOT qt5. It will not work with qt5 (at least, for my purposes it hasn't). Also note that there might be some unexpected issues in the future with this... But, try it. It's working fine for me.

One more thing: you will need to link python correctly. Run this command:

sudo ln -sf /usr/lib/x86_64-linux-gnu/libpython2.7.so.1 /usr/lib/libpython2.7.so

This will fix the python linking. Good luck!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-05-30 22:50:47 -0500

Seen: 1,994 times

Last updated: May 31 '13