Ask Your Question
18

Permission denied: .gvfs

asked 2013-09-06 11:24:48 -0500

Dereck gravatar image

updated 2013-09-18 04:34:01 -0500

when using roslaunch tab completion on Ubuntu 13.04 and Hydro I receive:

[rospack] Warning: error while crawling /home/dereck: boost::filesystem::status: Permission denied: "/home/dereck/.gvfs"

This system was installed from scratch today, any ideas?


ls shows some weird permissions: d????????? ? ? ? ? ? .gvfs/

Can't delete the directory even as root.


I rebooted and logged in via ssh, I was able to delete it and the permissions were normal. Something is causing ruckus when I log in to the desktop it seems.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
66

answered 2014-09-24 03:51:00 -0500

RagingBit gravatar image

I solved it like this (on Ubuntu 14.04):

#umount /home/useraccount/.gvfs
#rm -rf .gvfs/

hope that helped! :)

edit flag offensive delete link more

Comments

2

Perfect fix. I don't have this problem anymore. Thanks

pmarinplaza gravatar image pmarinplaza  ( 2014-09-29 09:26:05 -0500 )edit
1

Worked for me too. Thanks!

mmedonis gravatar image mmedonis  ( 2014-11-08 12:12:13 -0500 )edit
12

sudo umount /home/$USER/.gvfs

VictorLamoine gravatar image VictorLamoine  ( 2014-11-20 02:14:04 -0500 )edit
2

This worked for me too. Could you explain better what we have done? Thanks.

fabbro gravatar image fabbro  ( 2014-12-11 08:46:41 -0500 )edit
2

We have unmounted the Gnome virtual file system and deleted the mounting point. https://en.wikipedia.org/wiki/GVFS

VictorLamoine gravatar image VictorLamoine  ( 2014-12-16 02:39:28 -0500 )edit

Is this a good solution in case I'm using a distributed system with multiple machines?

zweistein gravatar image zweistein  ( 2015-10-27 08:09:47 -0500 )edit

Yeah, stackoverflow doesn't really solve this. It only tell you to umount /run/user/1000/gvfs and remove ~/.gvfs. Which doesn't help. But this one is rock!

zcam gravatar image zcam  ( 2016-05-23 06:47:06 -0500 )edit

perfect solution! remember to omit '#' though.

ZQ.Jones gravatar image ZQ.Jones  ( 2016-12-25 22:41:21 -0500 )edit
3

answered 2013-09-06 11:47:41 -0500

Dereck gravatar image

updated 2013-09-18 03:37:29 -0500

Reboot seemed to fix it... shrug

And now it's back, rebooting doesn't affect it... ? I've re-installed U13.04 now too...

edit flag offensive delete link more

Comments

Do you by any chance have an android device that you connect to you computer and after you did that once, this error appears?

dornhege gravatar image dornhege  ( 2013-09-18 03:40:51 -0500 )edit

I don't think so, but I suppose it's possible.

Dereck gravatar image Dereck  ( 2013-09-18 04:10:58 -0500 )edit

Might also be something else accessed via .gvfs. I suspect the completion tries to scan all directories (for some reason) and hits this one with an error.

dornhege gravatar image dornhege  ( 2013-09-18 04:21:57 -0500 )edit

Any way to make it go away? I've been Googling about for a while without too much luck. :/

Dereck gravatar image Dereck  ( 2013-09-18 04:23:06 -0500 )edit
1

From the non-ROS side, I had to unmount a broken mount that I mounted before - in my case an android device. I'm not sure if there are any tools to find out what this might be. From the ROS side, one could consider that warning a bug or feature. Is your home in ROS_PACKAGE_PATH?

dornhege gravatar image dornhege  ( 2013-09-18 04:27:52 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

7 followers

Stats

Asked: 2013-09-06 11:24:48 -0500

Seen: 26,291 times

Last updated: Sep 24 '14