Ask Your Question
0

Ogre Assertion failed causing rviz to crash

asked 2013-05-27 01:04:06 -0500

BenjaminV gravatar image

updated 2013-11-14 10:38:04 -0500

tfoote gravatar image

Hi,

I try to run the demo from moveit from the sources (as it is not working from packing answers.ros.org/question/63227/issue-with-moveit-tutorials/)

But whenever I try to launch a launch file, it is not working : I get the following error :

rviz: /build/buildd/ogre-1.7.4/OgreMain/src/OgreSceneManager.cpp :807 : virtual Ogre::SceneNode* Ogre::SceneManager::createSceneNode():  the assertion « mSceneNodes.find(sn->getName()) == mSceneNodes.end() » has failed.

It is driving me crazy! I made a fresh install on a VM and it is working perfectly!!

So I really don't know what's wrong with my system! I have the following configuration :

  • Intel Core i7­3720QM
  • Nvidia Quadro NVS 5200M GDDR5 1Go
  • RAM 8Go DDR3 (2X4Go) 1600MHz

I think it might be related to my graphic card driver but I'm not really sure about it.

Thanks

Ben

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2013-05-29 14:26:53 -0500

dgossow gravatar image

This doesn't look like a driver related problem, I would guess something in MoveIt is causing this.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-05-27 01:04:06 -0500

Seen: 296 times

Last updated: May 29 '13