Ask Your Question
3

rviz: OGRE EXCEPTION(3:RenderingAPIException): Unable to create a suitable GLXContext in GLXContext

asked 2011-05-25 00:56:35 -0600

rajat gravatar image

updated 2011-05-25 07:41:25 -0600

When i try to run "rosrun rviz rviz" i get this output :

[ INFO] [1306327198.635135186]: Loading general config from [/home/rajat/.rviz/config]
[ INFO] [1306327198.650256875]: Loading display config from [/home/rajat/.rviz/display_config]
[ERROR] [1306327199.295138649]: Caught exception while loading: OGRE EXCEPTION(3:RenderingAPIException): Unable to create a suitable GLXContext in GLXContext::GLXContext at /tmp/buildd/ros-diamondback-visualization-common-1.4.0/debian/ros-diamondback-visualization-common/opt/ros/diamondback/stacks/visualization_common/ogre/build/ogre_src_v1-7-1/RenderSystems/GL/src/GLX/OgreGLXContext.cpp (line 61)

After wasting more than 5 hours on this , i still can't figure out the solution. :( . Please help .

edit retag flag offensive close merge delete

Comments

Did you ever solve your problem?
Asomerville gravatar imageAsomerville ( 2011-06-03 06:06:11 -0600 )edit

Did you ever solve your problem?

harderthan gravatar imageharderthan ( 2018-12-20 02:15:12 -0600 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2011-06-14 23:32:09 -0600

rajat gravatar image

I got it working , i guess this is some issue with the video card drive . i was using ubnutu in a virtual machine inside windows , but now i installed it as a separate operating system along with the windows , and installed everything again . and everything seems to work fine now :).
i know this is not the solution , but if you have the same case give this method a try .

edit flag offensive delete link more

Comments

Actually it is the solution. 3D and virtual machines don't work well together and rviz/OGRE makes heavy use of 3D features.
dornhege gravatar imagedornhege ( 2011-06-15 00:03:12 -0600 )edit
2

answered 2011-05-25 07:40:11 -0600

updated 2011-05-25 09:06:19 -0600

I'm not sure why this would happen but my best guess is that you don't have MESA available.

You can test this by running glxinfo which should give you a bunch of information about the OpenGL renderers available whether through hardware or software.

If this is empty or fails to even run as well, then you'll need to install Mesa, GLX, and/or hardware drivers for your video card.

You can try glxgears as well to prove your OpenGL rendering hardware/software pipeline is working.

Also a shallow google search brings up this: http://www.ogre3d.org/forums/viewtopic.php?f=2&t=51227&start=0 where someone seemed to have the same problem because their X server GLX/DRI/OpenGL settings were messed up somehow.

edit flag offensive delete link more
0

answered 2019-11-15 05:53:09 -0600

astro gravatar image

I met the same problem. And I solved it by installing OpenGL library with an old version of Nvidia driver installer. For Ubuntu 16.04, I use 384.69

In the container, this command works:

nvidia-installer.run -a -N --ui=none --no-kernel-module

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-05-25 00:56:35 -0600

Seen: 5,775 times

Last updated: Jun 14 '11