Ask Your Question
0

OGRE linking to boost fails, OSX 10.7

asked 2013-05-25 22:53:35 -0600

Mike Shomin gravatar image

Trying to install groovy on my mac running lion. After appropriate tapping and following the instructions, brew install ogre (or brew install ros/groovy/ogre) gets me the following. I noticed in one of the patches that boost versions are only listed for up to 1.46.1, so I also tried reverting back to that version of boost via homebrew. I was using the newest in the homebrew repo, 1.53.0. It seems as though its just not getting the right flags, but I was concerned at it seems no one else has had this problem. Any help is appreciated. Thanks.

Linking CXX shared library ../lib/libOgreMain.dylib
brew: superenv removed: -arch x86_64 -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.7.sdk
Undefined symbols for architecture x86_64:
 "boost::this_thread::interruption_point()", referenced from:
 boost::condition_variable::wait(boost::unique_lock<boost::mutex>&) in OgreWorkQueue.cpp.o

...

boost::detail::thread_data_base::thread_data_base() in OgreDefaultWorkQueueStandard.cpp.o
NOTE: a missing vtable usually means the first non-inline virtual member function has no definition.
ld: symbol(s) not found for architecture x86_64
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[2]: *** [lib/libOgreMain.1.7.4.dylib] Error 1
make[1]: *** [OgreMain/CMakeFiles/OgreMain.dir/all] Error 2
make: *** [all] Error 2
==> Configuration
HOMEBREW_VERSION: 0.9.4
HEAD: 3e262a61605d8a635b67e29023de2134a2a8ea9d
CPU: quad-core 64-bit sandybridge
OS X: 10.7.5-x86_64
Xcode: 4.6.2
CLT: 1.0.0.9000000000.1.1249367152
LLVM-GCC: build 2336
Clang: 4.0 build 421
X11: 2.6.5 => /usr/X11
==> ENV
HOMEBREW_CC: clang
MAKEFLAGS: -j4
CMAKE_PREFIX_PATH: /usr/local/opt/freetype:/usr/local
CMAKE_INCLUDE_PATH: /usr/X11/include/freetype2:/usr/include/libxml2:/usr/X11/include
CMAKE_LIBRARY_PATH: /usr/X11/lib
PKG_CONFIG_PATH: /usr/local/opt/freetype/lib/pkgconfig:/usr/local/opt/libzzip/lib/pkgconfig
PKG_CONFIG_LIBDIR: /usr/lib/pkgconfig:/usr/X11/lib/pkgconfig:/usr/X11/share/pkgconfig
ACLOCAL_PATH: /usr/local/opt/freetype/share/aclocal:/usr/local/share/aclocal
OBJC: cc
PATH: /usr/local/Library/ENV/4.3:/usr/local/opt/cmake/bin:/usr/local/opt/doxygen/bin:/usr/local/opt/freetype/bin:/usr/local/opt/libzzip/bin:/usr/X11/bin:/usr/bin:/bin:/usr/sbin:/sbin
edit retag flag offensive close merge delete

Comments

I am not sure what the problem is, but all I can tell you is that I use boost 1.53 and it works fine for me.

Hansg91 gravatar imageHansg91 ( 2013-05-26 01:10:55 -0600 )edit

I can reproduce this problem now, looks like Ogre is going to need a patch of some sort.

William gravatar imageWilliam ( 2013-05-29 06:14:51 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-05-29 07:31:34 -0600

William gravatar image

I just posted a fix to the ogre formulae on the ros-groovy tap:

https://github.com/ros/homebrew-groovy/commit/12e84193bb59f7230d8523b3e44726906fd66aac

Try doing:

$ brew update
$ brew install ogre

Let me know if it doesn't work for you.

edit flag offensive delete link more

Comments

As always William, you have the answers/solutions. Thanks again for all your OSX/Homebrew/Github work. Much appreciated.

Mike Shomin gravatar imageMike Shomin ( 2013-05-30 19:16:24 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-05-25 22:53:35 -0600

Seen: 582 times

Last updated: May 29 '13