Ask Your Question
0

rosbag results in OSError

asked 2011-08-21 20:38:17 -0600

mrath gravatar image

updated 2012-02-20 11:34:11 -0600

Kevin gravatar image

Hello all, I'm trying to run this tutorial, but rosbag fails to record data. I tried both the specified instructions

rosbag record -a

as well as recording a single topic

rosbag record /turtle1/command_velocity

but either results in the same error:

Traceback (most recent call last):
  File "/Users/mrath/ros/ros/bin/rosbag", line 35, in <module>
    rosbag.rosbagmain()
  File "/Users/mrath/ros/ros_comm/tools/rosbag/src/rosbag/rosbag_main.py", line 807, in rosbagmain
    cmds[cmd](argv[2:])
  File "/Users/mrath/ros/ros_comm/tools/rosbag/src/rosbag/rosbag_main.py", line 115, in record_cmd
    os.execv(recordpath, cmd)
OSError: [Errno 2] No such file or directory

I'm running ROS in OS X Lion, which I suppose is the problem, but I have no clue to the solution, so please advise.

edit retag flag offensive close merge delete

Comments

Have you followed the guide to date for OSX Lion? It is currently very unstable, and would probably not make the best platform to learn on until it stabilizes a bit.
mjcarroll gravatar imagemjcarroll ( 2011-08-22 08:06:41 -0600 )edit
This: https://github.com/wjwwood/ros-osx/tree/master/electric-lion-homebrew is currently the best approach at getting ROS working on Lion. Many tools are still not working, so use at your own risk. I would suggest a Ubuntu VM for now.
mjcarroll gravatar imagemjcarroll ( 2011-08-22 09:58:36 -0600 )edit
The most up-to-date instructions now live at: http://www.ros.org/wiki/electric/Installation/OSX/Homebrew
William gravatar imageWilliam ( 2011-11-08 14:40:21 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-08-22 04:34:08 -0600

kwc gravatar image

This error probably means that rosbag has not been built properly. The most likely cause of the error is because rosbag/bin/record does not exist.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-08-21 20:38:17 -0600

Seen: 145 times

Last updated: Aug 22 '11