Ask Your Question
0

rxtools fails under osx Lion and HomeBrew

asked 2011-12-13 01:59:50 -0500

LucaGhera gravatar image

Hi all,

I'm following the tutorial reported here in order to install ROS on my MacBook pro with Lion.

I succeed in the installation of the basic stacks but now I'm blocked with Rviz. When I try to rosmake it the compilation of rxtools fails with the following error:

 -- Build files have been written to: /Users/luca/Software/ros/electric/rx/rxtools/build
  cd build && make -l8
  Scanning dependencies of target rospack_genmsg_libexe
  [  0%] Built target rospack_genmsg_libexe
  Scanning dependencies of target rosbuild_precompile
  [  0%] Built target rosbuild_precompile
  Scanning dependencies of target rxtools
  [  5%] Building CXX object CMakeFiles/rxtools.dir/src/rxtools/topic_display.o
  [ 11%] Building CXX object CMakeFiles/rxtools.dir/src/rxtools/topic_display_generated.o
  [ 16%] Building CXX object CMakeFiles/rxtools.dir/src/rxtools/topic_display_dialog.o
  [ 22%] Building CXX object CMakeFiles/rxtools.dir/src/rxtools/rosout_generated.o
  [ 27%] Building CXX object CMakeFiles/rxtools.dir/src/rxtools/rosout_panel.o
  [ 33%] Building CXX object CMakeFiles/rxtools.dir/src/rxtools/rosout_filter.o
  [ 38%] Building CXX object CMakeFiles/rxtools.dir/src/rxtools/rosout_text_filter.o
  [ 44%] Building CXX object CMakeFiles/rxtools.dir/src/rxtools/rosout_text_filter_control.o
  [ 50%] Building CXX object CMakeFiles/rxtools.dir/src/rxtools/rosout_severity_filter.o
  [ 55%] Building CXX object CMakeFiles/rxtools.dir/src/rxtools/rosout_severity_filter_control.o
  [ 61%] Building CXX object CMakeFiles/rxtools.dir/src/rxtools/rosout_list_control.o
  [ 66%] Building CXX object CMakeFiles/rxtools.dir/src/rxtools/rosout_setup_dialog.o
  /Users/luca/Software/ros/electric/rx/rxtools/src/rxtools/rosout_setup_dialog.cpp: In member function ‘virtual void rxtools::RosoutSetupDialog::onTopicBrowse(wxCommandEvent&)’:
  /Users/luca/Software/ros/electric/rx/rxtools/src/rxtools/rosout_setup_dialog.cpp:74: warning: ‘__s_getDataType’ is deprecated (declared at /Users/luca/Software/ros/electric/ros_comm/messages/rosgraph_msgs/msg_gen/cpp/include/rosgraph_msgs/Log.h:86)
  [ 72%] Building CXX object CMakeFiles/rxtools.dir/src/rxtools/logger_level_panel.o
  [ 77%] Building CXX object CMakeFiles/rxtools.dir/src/rxtools/init_roscpp.o
  Linking CXX shared library ../lib/librxtools.dylib
  ld: warning: ignoring file /Developer/SDKs/MacOSX10.7.sdk/System/Library/Frameworks//QuickTime.framework/QuickTime, file was built for unsupported file format which is not the architecture being linked (x86_64)
  Undefined symbols for architecture x86_64:
    "wxRichTextCtrl::wxRichTextCtrl(wxWindow*, int, wxString const&, wxPoint const&, wxSize const&, long, wxValidator const&, wxString const&)", referenced from:
        rxtools::TextboxDialog::TextboxDialog(wxWindow*, int, wxString const&, wxPoint const&, wxSize const&, long)in rosout_generated.o
    "wxRichTextBuffer::BeginBold()", referenced from:
        rxtools::RosoutListControl::onItemActivated(wxListEvent&)       in rosout_list_control.o
    "wxRichTextBuffer::BeginTextColour(wxColour const&)", referenced from:
        rxtools::RosoutListControl::onItemActivated(wxListEvent&)       in rosout_list_control.o
    "wxRichTextCtrl::ms_classInfo", referenced from:
        rxtools::TextboxDialog::onChar(wxKeyEvent&)      in rosout_list_control.o
  ld: symbol(s) not found for architecture x86_64
  collect2: ld returned 1 exit status
  make[3]: *** [../lib/librxtools.dylib] Error 1
  make[2]: *** [CMakeFiles/rxtools.dir/all] Error 2
  make[1]: *** [all] Error 2

How can I fix it? Thanks!

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2011-12-16 04:33:17 -0500

mjcarroll gravatar image

This is probably due to you using the incorrect version of wxWindows and wxPython. There is a note in the tutorial on how to fix this:

rosmake --rosdep-install rviz

This does a binary install of wxWindows and wxPython to be used with both rxtools and rviz.

edit flag offensive delete link more

Comments

@mjcarroll Thanks. Hi did it before but it doesn't work. Should I see wxPython and wxWindows in the list of the brew packages (`brew list`)? Cause I don't see them. Is it possible that I have some old files from macPorts?
LucaGhera gravatar imageLucaGhera ( 2011-12-18 18:24:34 -0500 )edit
You won't see it in brew list due to the way that it is installed. However, you should see it in $PREFIX/share/ros/wxpython-version.installed, where prefix is your brew prefix (`brew --prefix`). Also, you can test the wxPython install with the python shell using: `import wx; wx.version()`
mjcarroll gravatar imagemjcarroll ( 2011-12-19 01:20:17 -0500 )edit
It may also be worthwhile to rebuild all of ROS, as it looks like you have an architecture mismatch somewhere. Especially after removing the files that macports left behind.
mjcarroll gravatar imagemjcarroll ( 2011-12-19 01:21:39 -0500 )edit
@mjcarroll Actually it worked. I removed the file '$PREFIX/share/ros/wxpython-version.installed' and then executed 'rosdep install rviz'. Thanks!
LucaGhera gravatar imageLucaGhera ( 2011-12-19 01:59:49 -0500 )edit
0

answered 2012-08-14 19:46:22 -0500

Hi, I have exactly the same problem. But after trying the above solutions, I still got the same error in "rosmake rxtools", and "rosdep install rviz" just works fine. Did you successfully installed rviz at last? Thanks.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2011-12-13 01:59:50 -0500

Seen: 815 times

Last updated: Aug 14 '12