ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Error building geometry stack in OSX

asked 2011-08-12 05:22:51 -0500

LucaGhera gravatar image

updated 2014-01-28 17:10:11 -0500

ngrennan gravatar image

Hi all,

I'm trying to build the geometry stack on osx Lion bu I got the following error during the building of Eigen:

mkdir -p build
if [ ! -f eigen-3.0prebeta3.tar.bz2.md5sum ]; then echo "Error: Couldn't find md5sum file eigen-3.0prebeta3.tar.bz2.md5sum" && false; fi
`rospack find rosbuild`/bin/ build/eigen-3.0prebeta3.tar.bz2 `awk {'print $1'} eigen-3.0prebeta3.tar.bz2.md5sum`
[rosbuild] Downloading to build/eigen-3.0prebeta3.tar.bz2...Traceback (most recent call last):
  File "/Users/luca/Software/ros/ros/core/rosbuild/bin/", line 56, in <module>
  File "/Users/luca/Software/ros/ros/core/rosbuild/bin/", line 28, in main
    urllib.urlretrieve(uri, dest)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/", line 93, in urlretrieve
    return _urlopener.retrieve(url, filename, reporthook, data)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/", line 239, in retrieve
    fp =, data)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/", line 204, in open
    return self.open_unknown(fullurl, data)
  File "/opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/", line 216, in open_unknown
    raise IOError, ('url error', 'unknown url type', type)
IOError: [Errno url error] unknown url type: 'https'
make: *** [build/eigen/unpacked] Error 1

Do you know how I can fix it? I read somewhere that I should switch to urllib2 but I don't know how to do it.


edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted

answered 2011-08-29 10:02:13 -0500

LucaGhera gravatar image

I found a better solution:

cd /opt/local/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/lib-dynload/
sudo cp /System/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/lib-dynload/ .

I don't know way bu it seems that the module is not installed through macport.

edit flag offensive delete link more

answered 2011-08-12 10:01:31 -0500

LucaGhera gravatar image

updated 2011-08-12 10:01:54 -0500

I temporary fixed it by downloading

into geometry/eigen/build


edit flag offensive delete link more

answered 2011-08-12 08:02:28 -0500

tfoote gravatar image

From this stack overflow question axaroth's comment looks applicable. You need to recompile Python with OpenSSL installed/enabled.

edit flag offensive delete link more


So, `sudo port -f uninstall python26` -> `sudo port install openssl` -> `sudo port install python26`. I already tried it and it unlikely it doesn't work...
LucaGhera gravatar image LucaGhera  ( 2011-08-12 09:38:12 -0500 )edit
Luca, you probably need to install python26 with the openssl variant: `sudo port install python26 +openssl`. Let me know if that works. I am going to test this build with the built-in python.
William gravatar image William  ( 2011-08-12 13:03:41 -0500 )edit
@William It seems that the `openssl` variant is not available: . Anyway, I found a workaround. Look at my answer. Of course it is not the best way.
LucaGhera gravatar image LucaGhera  ( 2011-08-12 19:40:25 -0500 )edit
@LucaGhera Ah, I was looking at the dependencies, I feel silly, I will keep looking for an alternative.
William gravatar image William  ( 2011-08-13 05:06:09 -0500 )edit
@William I posted a better solution.
LucaGhera gravatar image LucaGhera  ( 2011-08-29 10:02:40 -0500 )edit

Question Tools


Asked: 2011-08-12 05:22:51 -0500

Seen: 320 times

Last updated: Aug 29 '11