Ask Your Question
0

no module named yaml

asked 2011-05-23 00:38:24 -0500

mariamaria gravatar image

updated 2014-01-28 17:09:43 -0500

ngrennan gravatar image

Dear ROS Team,

I have tried to install ROS on my Mac after having installed Macports etc as explained, and after typing "rosinstall ~/ros "http://packages.ros.org/cgi-bin/gen_rosinstall.py?rosdistro=diamondback&variant=desktop-full&overlay=no" in the terminal, I get the error message: ImportError: No module named yaml.

Do you have a hint?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
0

answered 2011-05-23 01:45:13 -0500

ralph gravatar image

Found that the soln described here works. Note that I had to open a new window to get the rosinstall command to work after taking all these steps - apparently, the path still wasn't being rehashed properly.

http://answers.ros.org/question/385/problem-with-mac-os-installation-with-yaml

It's ugly, and I don't like removing system files - but it worked.

edit flag offensive delete link more
1

answered 2011-06-11 05:43:31 -0500

Perchik gravatar image

If you're following the diamondback installation directions, you'll have python setuptools installed. With that you can run easy_install. We found that if you run sudo easy_install PyYAML this will install the right version of yaml.

edit flag offensive delete link more
0

answered 2011-06-13 19:47:03 -0500

KoenBuys gravatar image

I had the same problem on Ubuntu after upgrading from 10.10 to 11.04 my solution:

sudo aptitude install python-setuptools
sudo aptitude install python-yaml
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-05-23 00:38:24 -0500

Seen: 2,753 times

Last updated: Jun 13 '11