Ask Your Question
1

More problems building Ogre on OSX Lion [closed]

asked 2012-01-31 02:37:54 -0500

I'm trying to build ogre using the homebrew installation instructions and I'm getting an error similar, though not identical to this question. The solution there, and in the install guide in the wiki don't work.

Here's the relevant part of my build output:

Ld build/lib/RelWithDebInfo/Ogre.framework/Versions/1.7.3/Ogre normal x86_64
    cd /Users/lazewatskyd/ros/visualization_common/ogre/build/ogre_src_v1-7-3
    setenv MACOSX_DEPLOYMENT_TARGET 10.5
    /Developer/usr/bin/clang++ -arch x86_64 -dynamiclib -isysroot /Developer/SDKs/MacOSX10.7.sdk -L/Users/lazewatskyd/ros/visualization_common/ogre/build/ogre_src_v1-7-3/build/lib/RelWithDebInfo -L/usr/local/lib/RelWithDebInfo -L/Developer/SDKs/MacOSX10.7.sdk/usr/local/lib -F/Users/lazewatskyd/ros/visualization_common/ogre/build/ogre_src_v1-7-3/build/lib/RelWithDebInfo -F/Developer/SDKs/MacOSX10.7.sdk/Library/Frameworks -filelist /Users/lazewatskyd/ros/visualization_common/ogre/build/ogre_src_v1-7-3/build/OgreMain/OGRE.build/RelWithDebInfo/OgreMain.build/Objects-normal/x86_64/Ogre.LinkFileList -install_name "@rpath/Ogre.framework/Versions/1.7.3/Ogre" -mmacosx-version-min=10.5 -Wl,-rpath,/Users/lazewatskyd/ros/visualization_common/ogre/ogre/lib /usr/local/lib/libfreetype.dylib -framework Carbon -framework Cocoa /usr/local/lib/libboost_thread-mt.a /usr/local/lib/libboost_date_time-mt.a /usr/local/lib/libfreeimage.dylib /usr/local/lib/libzzip.dylib /usr/lib/libz.dylib -single_module -current_version 1.7.3 -o /Users/lazewatskyd/ros/visualization_common/ogre/build/ogre_src_v1-7-3/build/lib/RelWithDebInfo/Ogre.framework/Versions/1.7.3/Ogre
Command /Developer/usr/bin/clang++ failed with exit code 1


** BUILD FAILED **


The following build commands failed:
    Ld build/lib/RelWithDebInfo/Ogre.framework/Versions/1.7.3/Ogre normal x86_64
(1 failure)
make[1]: *** [installed_osx] Error 65
BUILD FAILED: Plugin_CgProgramManager.dylib not created.   Is nvidia-cg-toolkit installed correctly?
make: *** [ogre] Error 1

"setenv MACOSX_DEPLOYMENT_TARGET 10.5" seems like it probably isn't right, but I have no idea if that's related. Ideas?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2012-06-09 11:21:56

1 Answer

Sort by ยป oldest newest most voted
2

answered 2012-02-02 10:49:37 -0500

William gravatar image

The important error here is the line:

BUILD FAILED: Plugin_CgProgramManager.dylib not created.   Is nvidia-cg-toolkit installed correctly?

Perhaps nvidia's CG toolkit did not install correctly.

Please try this:

rm /usr/local/share/ros/nvidia-cg-version.installed
rosdep install ogre

Be ready to put in your password for sudo (nvidia cg's installation requires root access), then try building ogre again:

roscd ogre
make clean
rosmake ogre

If that doesn't work try installing nvidia's CG toolkit by downloading it from nvidia directly and running the installation app yourself, then try to make clean and rosmake ogre again.

edit flag offensive delete link more

Comments

Hmm, just tried both suggestions, and no luck (same error both times).
Dan Lazewatsky gravatar imageDan Lazewatsky ( 2012-02-02 11:27:36 -0500 )edit

Question Tools

Stats

Asked: 2012-01-31 02:37:54 -0500

Seen: 686 times

Last updated: Feb 02 '12