Ask Your Question
0

Project stopped being able to build

asked 2013-05-25 21:00:27 -0500

rocklobster gravatar image

updated 2014-01-28 17:16:38 -0500

ngrennan gravatar image

I have an ROS node project which I am developing using Eclipse. I have been able to build the project for some time, but tonight after updates were installed, the project is broken. I found one issue, which was the change from drcsim-2.5 to drcsim-2.6. I changed the include path in the eclipse properties, then did project->index->rebuild. However, I still get the errors below. In addition, when I run rosgui, all of the python based plug-ins are grayed out, whereas these worked previously. I have a custom python plugin which still works, because I manually set the path to my project. Finally, ROS_PACKAGE_PATH used to include a large number of packages, but now it only includes the packages I add. All of this suddenly stopped.

Has rosbuild and the use of ROS_PACKAGE_PATH been discontinued in the most recent update?

I would appreciate anyone's help as to how get back to being able to build my project.

UPDATE:

Rosgui now shows all the plugins like normal. This was apparently an error from starting it before I started the ros master. Also, after reading the error message a few more times, I see that rospack is reporting it can't find atlas_msgs. My manifest.xml file refers to this and several other drcsim related packages. Rospack is able to find regular ros packages such as roscpp or geometry_msgs, but it doesn't see any of the drcsim specific packages that I need to be able to call the the required message types. I double checked my project include paths, and also found the need to update from gazebo-1.7 to gazebo-1.8, but all the other paths still appear to be intact. When I first discovered this problem, the #include line for atlas_msgs/AtlasSimInterfaceState.h was broken, saying it couldn't see this file. This problem was fixed when I updated the include path from drcsim-2.5 to drcsim-2.6. If this corrected the ability to see the file to include it, why can't the compiler see atlas_msgs?

UPDATE 2:

I decided to try closing eclipse, and manually add the drcsim-2.6 package to the ROS_PACKAGE_PATH, but in the command window where I started eclipse, ROS_PACKAGE_PATH contains all the ros packages. I don't know why they appear in this terminal window, but not the others. I run the startup scripts for drcsim in the .bashrc, so I would thing any terminal window would show the same. I start eclipse using bash -i -c eclipse.

FIXED:

I had to update the C/C++ Make Project Environment variable for ROS_PACKAGE_PATH. It was still full of references to drcsim-2.5. I deleted the previous contents, and pasted in the path variables posted below, and was able to build successfully.

Here is my result for echo $ROS_PACKAGE_PATH

rick@field:~/catkin_ws$ echo $ROS_PACKAGE_PATH
/home/rick/ros_ws/:/home/rick/ros_ws:/usr/share/osrf-common-1.0/ros:/usr/share/drcsim-2.6/ros:/usr/share/sandia-hand-5.1/ros:/usr/share/drcsim-2.6/ros:/usr ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-05-25 22:05:25 -0500

rocklobster gravatar image

Fixed

I had to manually update the ROS_PACKAGE_PATH data in the project properties under C/C++ Make Project->Environment.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-05-25 21:00:27 -0500

Seen: 127 times

Last updated: May 26 '13