Ask Your Question
1

Several died after update ros-fuerte-navigation version 1.8.3

asked 2013-05-09 05:17:41 -0500

updated 2013-05-09 05:18:05 -0500

Dear Ros community,

After the last update in ros fuerte, move_base and map_server die after launch them with launch apps [1][2] that used to work properly.

They doesn't give much information, for instance:

[move_base-3] process has died [pid 10283, exit code -4, [...]

I tried to find a solution and I haven't found any.

This is the configuration of the system:

  • Ubuntu 12.04 64bit
  • ROS Fuerte
  • ros-fuerte-navigation 1.8.3-s1367591379~precise

Has anybody found a similar problem? or have a clue of a possible problem/solution?

Thanks in advance,

see you saturday!

[1] http://devel.iri.upc.edu/pub/labrobotica/ros/iri-ros-pkg/stacks/iri_teaching/upc_mobrob/launch/fuerte/sim_stage_navigation.launch

[2] http://devel.iri.upc.edu/pub/labrobotica/ros/iri-ros-pkg/stacks/iri_teaching/upc_mobrob/launch/fuerte/sim_move_base.launch

edit retag flag offensive close merge delete

Comments

I am having major problems since the last Fuerte update as well. Every node I try and run that uses pcl is crashing. I'm guessing something went wrong during packaging. I filed a bug report with perception_pcl (wrong place) error here

jarvisschultz gravatar image jarvisschultz  ( 2013-05-09 05:36:20 -0500 )edit

Thanks @jarvisschultz, I followed the instructions of the patch there and it worked.

martimorta gravatar image martimorta  ( 2013-05-14 00:37:16 -0500 )edit

What does the log file for the move-base node contain?

tfoote gravatar image tfoote  ( 2013-05-27 16:37:12 -0500 )edit

Hi Tully, It says log file: /home/chaplin/.ros/log/3a0dfd2e-c790-11e2-9b26-c417fe1f097c/move_base-3*.log but there's not actual log file and the logs don't give other information.

martimorta gravatar image martimorta  ( 2013-05-28 02:28:53 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-05-09 07:12:31 -0500

hersh gravatar image

How did you get the latest Fuerte update? Did you do it with "apt-get update" and "apt-get install ..." or "apt-get upgrade"? I have seen problems with version dependencies not being modeled super carefully in the ROS debian packages (they tell me it is difficult, and I don't doubt it).

The result is they recommend to always upgrade by doing

sudo apt-get update
sudo apt-get dist-upgrade

"dist-upgrade" upgrades every package in your system to the latest available. It takes longer, but is more reliable with ROS packages.

If all that does not help, I usually follow the instructions here to run just the node in question in gdb, so I can get a stack trace.

edit flag offensive delete link more

Comments

Thank you, I'll try it as soon as I can. And yes, I did upgrade not dist-upgrade.

martimorta gravatar image martimorta  ( 2013-05-09 09:33:49 -0500 )edit

Hi, this solution hasn't worked, but thanks for the answer, it may be useful another time.

martimorta gravatar image martimorta  ( 2013-05-13 23:19:40 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-05-09 05:17:41 -0500

Seen: 478 times

Last updated: May 09 '13