Ask Your Question
2

tf frames in different time epoch from ros time?

asked 2013-05-08 20:38:54 -0500

Ernest gravatar image

updated 2014-01-28 17:16:28 -0500

ngrennan gravatar image

I am trying to tackle the following warning when running Navigation:

[ WARN] [1368081077.201722266]: Could not get robot pose, cancelling reconfiguration
[ WARN] [1368081077.401579990]: Costmap2DROS transform timeout. Current time: 1368081077.4015, global_pose stamp: 136.4000, tolerance: 0.3000

The transform timed out because the time & the pose stamp are extremely different. Are they in different time epochs? If so, how can that be solved?

Thanks,

Ernest

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
3

answered 2013-05-09 01:31:12 -0500

You're probably running Gazebo and missing the use_sim_time parameter. Try the following:

  1. roscore
  2. rosparam set use_sim_time true
  3. Now start launching the rest of your system.

The explanation is that the navigation stack was probably launched before the use_sim_time parameter was set (so it uses wall time: 1368081077.4015), and the thing publishing the TF transforms was launched afterwards (so it uses sim time: 136.4000).

edit flag offensive delete link more

Comments

spot on! that solved the problem. Thank you very much.

Ernest gravatar image Ernest  ( 2013-05-09 08:34:03 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-05-08 20:38:54 -0500

Seen: 537 times

Last updated: May 09 '13