Ask Your Question
0

openni_tracker on pioneer: illegal instruction

asked 2013-04-16 13:37:54 -0600

arturbp gravatar image

updated 2016-10-24 08:35:36 -0600

ngrennan gravatar image

hi,

I'm trying to use an on-board kinect on a P3-DX pioneer (Cobra EBX-12 Computer) with ros fuerte installed using openni.

The problem appears when I run the openni_tracker node. The node seems to work, but in a few seconds, before it displays any message or something, the message "Illegal instruction (core dumped)" is shown in screen and the node is killed...

I've once fixed http://answers.ros.org/question/42654/openninite-incompatible-in-fuertegroovy-on-precise/ (another) problem when I was trying to run the openni_tracker node in my computer but now, on the robot, the problem seems to be different...

Does anyone know what could be the problem? Could it be related with some computer architecture incompatibility? I downloaded the openni_tracker from the ubuntu repository and I am using ubuntu 12.04 32 bits.

edit retag flag offensive close merge delete

Comments

i don't have enough karma to post links, sorry...

arturbp gravatar imagearturbp ( 2013-04-16 13:39:14 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-12-20 08:07:13 -0600

heyfred gravatar image

Have you checked the version of NITE that you have downloaded? I think I had a similar problem when I was using a 64 bit version of Ubuntu and installed the 32 bit version of NITE.

You'll want the x86 version of the NITE release you downloaded.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-04-16 13:37:54 -0600

Seen: 228 times

Last updated: Dec 20 '13