ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

irobot_create_2_1 installation not working

asked 2013-04-15 23:32:16 -0500

Dayanand gravatar image

I tried to install irobot_create_2_1 package but the installation failed during the make step. I followed the steps as given in the following link (

When i run "rosmake irobot_create_2_1 ", the following is the output I get.

   user@ubuntu:~/groovy_workspace/brown_drivers/irobot_create_2_1$ rosmake irobot_create_2_1 
[ rosmake ] rosmake starting...                                                                                          
[ rosmake ] Packages requested are: ['irobot_create_2_1']                                                                
[ rosmake ] Logging to directory /home/user/.ros/rosmake/rosmake_output-20130416-140004                                  
[ rosmake ] Expanded args ['irobot_create_2_1'] to:
[rosmake-0] Starting >>> catkin [ make ]                                                                                 
[rosmake-0] Finished <<< catkin ROS_NOBUILD in package catkin                                  [ 1 Active 0/35 Complete ]
 No Makefile in package catkin                             
[rosmake-0] Starting >>> genmsg [ make ]                                                                                 
[rosmake-1] Starting >>> cpp_common [ make ]                                                                             
[rosmake-0] Finished <<< genmsg ROS_NOBUILD in package genmsg
 No Makefile in package genmsg                             
[rosmake-0] Starting >>> genlisp [ make ]                                                                                
[rosmake-0] Finished <<< genlisp ROS_NOBUILD in package genlisp
 No Makefile in package genlisp                          
[rosmake-0] Starting >>> genpy [ make ]                                                                                  
[rosmake-0] Finished <<< genpy ROS_NOBUILD in package genpy
 No Makefile in package genpy                                
[rosmake-0] Starting >>> gencpp [ make ]                                                                                 
[rosmake-0] Finished <<< gencpp ROS_NOBUILD in package gencpp
 No Makefile in package gencpp                             
[rosmake-0] Starting >>> message_generation [ make ]                                                                     
[rosmake-0] Finished <<< message_generation ROS_NOBUILD in package message_generation
 No Makefile in package message_generation
[rosmake-0] Starting >>> rospack [ make ]                                                                                
[rosmake-0] Finished <<< rospack ROS_NOBUILD in package rospack
 No Makefile in package rospack                          
[rosmake-0] Starting >>> roslib [ make ]                                                                                 
[rosmake-1] Finished <<< cpp_common ROS_NOBUILD in package cpp_common
 No Makefile in package cpp_common                 
[rosmake-1] Starting >>> rostime [ make ]                                                                                
[rosmake-1] Finished <<< rostime ROS_NOBUILD in package rostime
 No Makefile in package rostime                          
[rosmake-1] Starting >>> roscpp_traits [ make ]                                                                          
[rosmake-1] Finished <<< roscpp_traits ROS_NOBUILD in package roscpp_traits
 No Makefile in package roscpp_traits        
[rosmake-0] Finished <<< roslib ROS_NOBUILD in package roslib
 No Makefile in package roslib                             
[rosmake-0] Starting >>> rosunit [ make ]                                                                                
[rosmake-0] Finished <<< rosunit ROS_NOBUILD in package rosunit
 No Makefile in package rosunit                          
[rosmake-0] Starting >>> rosconsole [ make ]                                                                             
[rosmake-0] Finished <<< rosconsole ROS_NOBUILD in package rosconsole
 No Makefile in package rosconsole                 
[rosmake-1] Starting >>> roscpp_serialization [ make ]                                                                   
[rosmake-1] Finished <<< roscpp_serialization ROS_NOBUILD in package roscpp_serialization
 No Makefile in package roscpp_serialization
[rosmake-1] Starting >>> message_runtime [ make ]                                                                        
[rosmake-1] Finished <<< message_runtime ROS_NOBUILD in package message_runtime
 No Makefile in package message_runtime  
[rosmake-0] Starting >>> roslang [ make ]                                                                                
[rosmake-0] Finished <<< roslang ROS_NOBUILD in package roslang
 No Makefile in package roslang                          
[rosmake-0] Starting >>> xmlrpcpp [ make ]                                                                               
[rosmake-0] Finished <<< xmlrpcpp ROS_NOBUILD in package xmlrpcpp
 No Makefile in package xmlrpcpp                       
[rosmake-1] Starting >>> std_msgs [ make ]                                                                               
[rosmake-1] Finished <<< std_msgs ROS_NOBUILD in package std_msgs
 No Makefile in package std_msgs                       
[rosmake-1] Starting >>> rosgraph_msgs [ make ]                                                                          
[rosmake-1] Finished <<< rosgraph_msgs ROS_NOBUILD in package rosgraph_msgs
 No Makefile in package rosgraph_msgs        
[rosmake-0] Starting >>> rosgraph [ make ]                                                                               
[rosmake-0] Finished <<< rosgraph ROS_NOBUILD in package rosgraph
 No Makefile in package rosgraph                       
[rosmake-0] Starting >>> geometry_msgs [ make ]                                                                          
[rosmake-0] Finished <<< geometry_msgs ROS_NOBUILD in package geometry_msgs
 No Makefile in package geometry_msgs        
[rosmake-0] Starting >>> rosparam [ make ]                                                                               
[rosmake-1] Starting >>> roscpp [ make ]                                                                                 
[rosmake-1] Finished <<< roscpp ROS_NOBUILD in package roscpp
 No Makefile in package roscpp                             
[rosmake-1] Starting >>> rospy [ make ]                                                                                  
[rosmake-1] Finished <<< rospy ROS_NOBUILD in package rospy
 No Makefile in package rospy                                
[rosmake-0] Finished <<< rosparam ROS_NOBUILD in package rosparam
 No Makefile in package rosparam                       
[rosmake-0] Starting >>> rosmaster [ make ]                                                                              
[rosmake-0] Finished <<< rosmaster ROS_NOBUILD in package rosmaster
 No Makefile in package rosmaster                    
[rosmake-0] Starting >>> rosout [ make ]                                                                                 
[rosmake-0] Finished <<< rosout ROS_NOBUILD in package rosout
 No Makefile in package rosout                             
[rosmake-0] Starting >>> rosclean [ make ]                                                                               
[rosmake-1] Starting >>> sensor_msgs [ make ...
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted

answered 2013-04-17 00:24:27 -0500

Works for me. This question has a similar error message:

get_dependencies() got an unexpected keyword argument 'rospack'

One answer mentioned that updating roslib solved it, so maybe you could try that.

edit flag offensive delete link more


Thank you Martin. Updating roslib has solved the problem.

Dayanand gravatar image Dayanand  ( 2013-04-17 02:13:15 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools


Asked: 2013-04-15 23:32:16 -0500

Seen: 280 times

Last updated: Apr 17 '13