Ask Your Question
1

map_server

asked 2013-04-09 11:09:41 -0500

JaRu gravatar image

updated 2013-04-11 22:07:42 -0500

Hi all!

I tried rosrun map_server map_server testmap.yaml and get the message

[rosrun] Couldn't find executable named map_server below /opt/ros/electric/stacks/navigation/map_server
[rosrun] Found the following, but they're either not files, 
[rosrun] or not executable:
[rosrun]   /opt/ros/electric/stacks/navigation/map_server
[rosrun]   /opt/ros/electric/stacks/navigation/map_server/include/map_server

Why it does not work?

Do I have anything to do after the installation, before i can start it?

Thanks for help!

The rosmake map_server does not work right: (The bin folder is empty.)

[ rosmake ] Packages requested are: ['map_server']                              
[ rosmake ] Logging to directory/home/jaru/.ros/rosmake/rosmake_output-20130411-122637 
[ rosmake ] Expanded args ['map_server'] to: 
['map_server']                     
[ rosmake ] Checking rosdeps compliance for packages map_server.  This may take a few seconds. 
Failed to find rosdep sdl-image for package map_server on OS:ubuntu version:lucid 
WARNING: Rosdeps [u'sdl-image'] could not be resolved 
Failed to find rosdep sdl-image for package map_server on OS:ubuntu version:lucid 
[ rosmake ] rosdep check failed to find system dependencies: sdl-image          
[rosmake-0] Starting >>> cpp_common [ make ]                                    
[rosmake-0] Finished <<< cpp_common ROS_NOBUILD in package cpp_common           
[rosmake-1] Starting >>> rosbuild [ make ]                                      
[rosmake-1] Finished <<< rosbuild ROS_NOBUILD in package rosbuild 
 No Makefile in package rosbuild 
[rosmake-2] Starting >>> roslib [ make ]                                        
[rosmake-2] Finished <<< roslib ROS_NOBUILD in package roslib                   
[rosmake-3] Starting >>> bullet [ make ]                                        
[rosmake-0] Starting >>> rostime [ make ]                                       
[rosmake-1] Starting >>> roslang [ make ]                                       
[rosmake-2] Starting >>> roscpp_traits [ make ]                                 
[rosmake-1] Finished <<< roslang ROS_NOBUILD in package roslang 
 No Makefile in package roslang 
[rosmake-1] Starting >>> xmlrpcpp [ make ]                                      
[rosmake-0] Finished <<< rostime ROS_NOBUILD in package rostime                 
[rosmake-0] Starting >>> rosconsole [ make ]                                    
[rosmake-2] Finished <<< roscpp_traits ROS_NOBUILD in package roscpp_traits     
[rosmake-2] Starting >>> roscpp_serialization [ make ]                          
[rosmake-3] Finished <<< bullet ROS_NOBUILD in package bullet                   
[rosmake-0] Finished <<< rosconsole ROS_NOBUILD in package rosconsole           
[rosmake-1] Finished <<< xmlrpcpp ROS_NOBUILD in package xmlrpcpp               
[rosmake-2] Finished <<< roscpp_serialization ROS_NOBUILD in package roscpp_serialization 
[rosmake-0] Starting >>> std_msgs [ make ]                                      
[rosmake-2] Starting >>> rosclean [ make ]                                      
[rosmake-3] Starting >>> rosgraph [ make ]                                      
[rosmake-1] Starting >>> rosparam [ make ]                                      
[rosmake-0] Finished <<< std_msgs ROS_NOBUILD in package std_msgs               
[rosmake-2] Finished <<< rosclean ROS_NOBUILD in package rosclean               
[rosmake-2] Starting >>> rosmaster [ make ]                                     
[rosmake-1] Finished <<< rosparam ROS_NOBUILD in package rosparam               
[rosmake-0] Starting >>> rosgraph_msgs [ make ]                                 
[rosmake-2] Finished <<< rosmaster ROS_NOBUILD in package rosmaster             
[rosmake-1] Starting >>> rosunit [ make ]                                       
[rosmake-1] Finished <<< rosunit ROS_NOBUILD in package rosunit                 
[rosmake-0] Finished <<< rosgraph_msgs ROS_NOBUILD in package rosgraph_msgs     
[rosmake-3] Finished <<< rosgraph ROS_NOBUILD in package rosgraph               
[rosmake-1] Starting >>> angles [ make ]                                        
[rosmake-0] Starting >>> roscpp [ make ]                                        
[rosmake-2] Starting >>> rospy [ make ]                                         
[rosmake-1] Finished <<< angles ROS_NOBUILD in package angles                   
[rosmake-0] Finished <<< roscpp ROS_NOBUILD in package roscpp                   
[rosmake-2] Finished <<< rospy ROS_NOBUILD in package rospy                     
[rosmake-3] Starting >>> rosnode [ make ]                                       
[rosmake-3] Finished <<< rosnode ROS_NOBUILD in package rosnode                 
[rosmake-2] Starting >>> rosout [ make ]                                        
[rosmake-2] Finished <<< rosout ROS_NOBUILD in package rosout                   
[rosmake-2] Starting >>> roslaunch [ make ]                                     
[rosmake-2] Finished <<< roslaunch ROS_NOBUILD in package roslaunch 
 No Makefile in package roslaunch 
[rosmake-2] Starting >>> rostest [ make ]                                       
[rosmake-2] Finished <<< rostest ROS_NOBUILD in package rostest                 
[rosmake-2] Starting >>> topic_tools [ make ]                                   
[rosmake-0] Starting >>> message_filters [ make ]                               
[rosmake-2] Finished <<< topic_tools ROS_NOBUILD in package topic_tools         
[rosmake-0] Finished <<< message_filters ROS_NOBUILD in package message_filters 
[rosmake-2] Starting >>> rosbag [ make ]                                        
[rosmake-2] Finished <<< rosbag ROS_NOBUILD in package rosbag                   
[rosmake-2] Starting >>> rosbagmigration [ make ]                               
[rosmake-1] Starting >>> rosmsg [ make ]                                        
[rosmake-2] Finished <<< rosbagmigration ROS_NOBUILD in package rosbagmigration 
 No Makefile in package rosbagmigration 
[rosmake-2 ...
(more)
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
2

answered 2013-04-10 01:41:00 -0500

updated 2013-04-11 22:15:16 -0500

This is weird. There should be an executable called map_server in that package. What does the following command give you?

$ ls -l /opt/ros/electric/stacks/navigation/map_server/bin/map_server 
-rwxr-xr-x 1 root root 1498250 2012-05-09 06:23 /opt/ros/electric/stacks/navigation/map_server/bin/map_server

Update: It looks like you are running rosmake as root (using sudo?) in the /opt/... directory. You should never do that. Something like this is probably also the cause of your problems. Instead, reinstall the deb package, as Felix suggested. The command is:

sudo apt-get install --reinstall ros-electric-navigation
edit flag offensive delete link more

Comments

ls: cannot access /opt/ros/electric/stacks/navigation/map_server/bin/map_server: No such file or directory. The bin folder exists, but he is empty. I think that is because I get error messages when I do rosmake map_server. I add this to my question, so you can look at it. Maybe you can help me.

JaRu gravatar image JaRu  ( 2013-04-11 01:59:24 -0500 )edit

Reinstall the respective ros package

Felix Endres gravatar image Felix Endres  ( 2013-04-11 04:49:28 -0500 )edit

I tried, but the command rosdep install map_server give me the command: Failed to find rosdep sdl-image for package map_server on OS:ubuntu version:lucid rosdep install ERROR: failed to install sdl-image

JaRu gravatar image JaRu  ( 2013-04-11 11:42:42 -0500 )edit

I've updated my answer, see above.

Martin Günther gravatar image Martin Günther  ( 2013-04-11 22:13:44 -0500 )edit

sudo apt-get install --reinstall ros-electric-navigation give the command that some packages could not installed, because ros-electric-navigation depend on libsdl-image1.2-dev, but should not installed because E: broken package

JaRu gravatar image JaRu  ( 2013-04-12 23:39:40 -0500 )edit

When I like to install libsdl-image1.2-dev I have the same problem, could not install, because depends on libsdl1.2-dev. But libsdl1.2-dev is already installed... I do not know what I can do now.

JaRu gravatar image JaRu  ( 2013-04-13 00:29:12 -0500 )edit

What it probably says that it depends on libsdl1.2-dev in a specific version that's newer than your installed version. Try sudo apt-get update; sudo apt-get dist-upgrade; sudo apt-get install libsdl-image1.2-dev. Hope that helps.

Martin Günther gravatar image Martin Günther  ( 2013-04-13 02:19:06 -0500 )edit

I tried, but unfortunately I got the same command, it does not work.

JaRu gravatar image JaRu  ( 2013-04-15 13:58:47 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-04-09 11:09:41 -0500

Seen: 1,556 times

Last updated: Apr 11 '13