Ask Your Question
1

Enabling depth reigstration

asked 2013-04-07 20:07:35 -0600

Chik gravatar image

updated 2013-04-07 20:08:03 -0600

After roslaunch openni_launch openni.launch, then rosrun dynamic_reconfigure reconfigure_gui, I select /camera/driver, but nothing shows up on the reconfigure window, and the following error is shown on the openni.launch terminal:

[ERROR] [1365395678.038589497]: Client [/reconfigure_gui_13810_1365391644607] wants topic /camera/driver/parameter_descriptions to have datatype/md5sum [dynamic_reconfigure/ConfigDescription/757ce9d44ba8ddd801bb30bc456f946f], but our version has [dynamic_reconfigure/ConfigDescription/5f0f929417f58ac7f30dfdd9e4d40ef2]. Dropping connection.

What is wrong?

Thank you very much for your help.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-04-07 23:53:40 -0600

Chik gravatar image

Thank you very much, Philip. I discovered the reason. I am using Electric in Turtlebot laptop but Fuerte in workstation. Perhaps the datatype changes when the ROS version changes. I run dynamic_reconfigure from the turtlebot laptop, then it is okay. And in rviz (run from workstation) the registered point cloud looks very nice.

edit flag offensive delete link more
1

answered 2013-04-07 23:41:49 -0600

Philip gravatar image

I don't know about the problem, but if you just want to (statically) enable registration, you can edit your openni.launch file.

Change

<arg name="depth_registration" default="false" />

to

<arg name="depth_registration" default="true" />

to enable depth registration by default.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-04-07 20:07:35 -0600

Seen: 227 times

Last updated: Apr 07 '13