ros-fuerte openni.launch unable to find usb device [closed]

asked 2012-06-03 07:48:02 -0500

nios gravatar image

updated 2014-01-28 17:12:33 -0500

ngrennan gravatar image

Hi all!

I have a fresh install of ros-fuerte. I'm trying to start working with kinekt camera. So, I use:

roslaunch openni_launch openni.launch

But the output contains tons of errors like these at first

Exception AttributeError: AttributeError("'_DummyThread' object has no attribute '_Thread__block'",) in <module 'threading' from '/usr/lib/python2.7/threading.pyc'> ignored

and then I see an error message like this:

[ INFO] [1338745409.467378076]: Number devices connected: 1
[ INFO] [1338745409.467555102]: 1. device on bus 002:04 is a Xtion Pro (600) from ASUS (1d27) with serial id ''
[ INFO] [1338745409.468875705]: Searching for device with index = 1
[ INFO] [1338745409.473786315]: No matching device found.... waiting for devices. Reason: openni_wrapper::OpenNIDevice::OpenNIDevice(xn::Context&, const xn::NodeInfo&, const xn::NodeInfo&, const xn::NodeInfo&) @ /tmp/buildd/ros-fuerte-openni-camera-1.8.0/debian/ros-fuerte-openni-camera/opt/ros/fuerte/stacks/openni_camera/src/openni_device.cpp @ 99 : creating depth generator failed. Reason: Failed to open the USB device!

I've been trying to find any workaround for the whole day, but still no luck. Does anyone have any guesses what may be the problem?

UPD I've managed to overcome the issue by killing XnSensorServer like this:

killall XnSensorServer

So now it eventially found my device:

[ INFO] [1338817322.032348748]: Opened 'PrimeSense Device' on bus 2:4 with serial number ''
[ INFO] [1338817322.055454616]: rgb_frame_id = '/camera_rgb_optical_frame' 
[ INFO] [1338817322.055518931]: depth_frame_id = '/camera_depth_optical_frame'

The problem now appears when I try to execute rviz

terminate called after throwing an instance of 'openni_wrapper::OpenNIException'
  what():  virtual void openni_wrapper::OpenNIDevice::startImageStream() @ /tmp/buildd/ros-fuerte-openni-camera-1.8.0/debian/ros-fuerte-openni-camera/opt/ros/fuerte/stacks/openni_camera/src/openni_device.cpp @ 224 : starting image stream failed. Reason: Xiron OS got an event timeout!
[camera_nodelet_manager-2] process has died [pid 3417, exit code -6, cmd /opt/ros/fuerte/stacks/nodelet_core/nodelet/bin/nodelet manager __name:=camera_nodelet_manager __log:=/home/igor/.ros/log/b580de32-ae4a-11e1-b34d-d0df9aa0a99d/camera_nodelet_manager-2.log].
log file: /home/igor/.ros/log/b580de32-ae4a-11e1-b34d-d0df9aa0a99d/camera_nodelet_manager-2*.log

So there is still plenty of what i don't understand. Does anyone have any ideas how to get rid of those errors?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2014-07-06 23:55:18.592067

Comments

The threading exceptions are documented here: http://answers.ros.org/question/34304/exception-attributeerror-when-starting-roscore/ and should be unrelated.

tfoote gravatar image tfoote  ( 2012-06-03 07:56:41 -0500 )edit

Yes, they also appeared on the previous version of ros and still everything worked. the problem is that ros can't see the kinekt camera connected...

nios gravatar image nios  ( 2012-06-04 00:25:00 -0500 )edit

Even i have the same issue and am unable to solve the same... any suggestion would greatly help... I did remove the error once but i dunno how i resolved it... ;)

SivamPillai gravatar image SivamPillai  ( 2012-08-01 06:37:49 -0500 )edit

I have similar problem, trying rostopic echo for the first time after launching openni it works, but for the second it does not, and manager dies with the same error.

liborw gravatar image liborw  ( 2012-09-10 01:46:46 -0500 )edit