Ask Your Question
0

After update UWSim only with --disableShaders

asked 2013-04-03 11:16:30 -0500

Marija-123 gravatar image

updated 2014-01-28 17:16:02 -0500

ngrennan gravatar image

I have installed ROS Groovy and UWSim and everything was working fine. Next day Ubuntu "Update Manager" said there is cca 100 updates recommended and I updated everything. After that I can run UWSim only with

rosrun UWSim UWSim --disableShaders

What I need to do to repair that so I can run UWSim normally?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-04-04 22:12:15 -0500

Javier Perez gravatar image

Hi,

UWSim has some pending issues with ocean shaders on some graphic cards from osgOcean visual effects but if it worked earlier it should work. You should check your graphics card configuration. If you are running UWSim on a laptop make sure you are running dedicated graphics card instead of proccesor for UWSim (common error). Some modern nvidia cards on laptops require a bumblebee installation and run UWSim with optirun.

Anyway shaders are a graphic issue so if it was working before the update problem must be on graphic configuration.

Besides that are you using Groovy?, as far as I know latest versions of UWSim do not support Groovy provided that osgWorks version used in UWSim is not working on it. Did you fixed that? or are you using an earlier version?. Just wondering...

edit flag offensive delete link more

Comments

I`m not using laptop, my graphics card is ATI Radeon HD 4600 Series it should work. I run latest version of UWSim on ubuntu on virtual machine... Did not know that that do not support groovy. But it word earlier? What should i do?

Marija-123 gravatar image Marija-123  ( 2013-04-04 23:18:48 -0500 )edit

what i run UWSim it says: [ INFO] [1365152628.435978708]: pluginlib WARNING: PLUGINLIB_DECLARE_CLASS is deprecated, please use PLUGINLIB_EXPORT_CLASS instead. You can run the script 'plugin_macro_update' provided with pluginlib in your package source folder to automatically and recursively update le

Marija-123 gravatar image Marija-123  ( 2013-04-04 23:36:37 -0500 )edit

legacy macros

Marija-123 gravatar image Marija-123  ( 2013-04-04 23:37:21 -0500 )edit

So it should be something about drivers. Do you know if any of that updates were related to graphic drivers?. I would go for checking 3d acceleration and graphic drivers something may have broken.

Javier Perez gravatar image Javier Perez  ( 2013-04-05 01:07:58 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-04-03 11:16:30 -0500

Seen: 271 times

Last updated: Apr 04 '13