Ask Your Question
0

android_core tutorials: no communication to roscore

asked 2013-03-29 02:53:35 -0500

noe_vb gravatar image

updated 2014-01-28 17:15:58 -0500

ngrennan gravatar image

I successfully installed and builder android_core. I encountered some problems but could fix them. I installed the android_tutorial_camera and android_tutorial_pubsub on the android device. Allthough both apps can run, there is no connection to the computer where the roscore runs. rosnode/rostopic list doesn't show any marks of the android device.

I tried it with 2 computers and 2 android devices with all possible combinations:

  • Laptop Ubuntu 10.04 with ROS electric
  • Desktop Ubuntu 11.10 with ROS fuerte
  • Samsung galaxy ace with android 2.3.3
  • Samsung galaxy tab 2 with android 4.0.4

None of the following URI's worked:

  • http: //< my_IP >:11311
  • http: //localhost:11311
  • http: //noe-laptop:11311

For the pubsub tutorial I also adapted the network adapter (link in comment).

Please help me! Thank you, Noë

edit retag flag offensive close merge delete

Comments

Links: android_core: http://ros.org/wiki/android_core network adapter pubsub: http://answers.ros.org/question/45314/wrong-network-adapter-with-inetaddressfactorynewnonloopback/

noe_vb gravatar imagenoe_vb ( 2013-03-29 02:54:42 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2013-03-29 03:30:23 -0500

130s gravatar image

updated 2013-03-29 09:08:00 -0500

Just wanted to make sure that (1) your Android device can communicate roscore machines (eg. by ping, http etc)? (2) Is my_IP your roscore machine not your Android right? (3) No space b/w "http" and "//" ok?


Update) For (1), if 2 computers can communicate over IP, there's no way that a node on a computer connects to roscore that's running on another machine.

In general, it's worthwhile to check NetworkSetup, although some of the checkups there might not work for Android.

I'm not 100% sure if pinging in LAN succeeds in any situation, but at least http should go through. Easiest (not the most optimal though) way to check connection b/w 2 machines if roscore runs on Ubuntu might be running http server on it and access from Android. Can be done as:

On_Ubuntu$ sudo apt-get install apache2

Then on Android, open http://IP_Ubuntu.

edit flag offensive delete link more

Comments

(1): no I do not manage to make them communicate (2) my_IP is from my laptop on which I run the roscore (3) I put the space there because I'm not allowed to post links already since I'm a new user of this website. Thanks already !

noe_vb gravatar imagenoe_vb ( 2013-03-29 03:41:17 -0500 )edit

Update for (1): The master is my Linux machine and the android app generates its own roscore. I made a web server with apache2 but, although both computer and tablet are connected to the same wifi AND with a USB cable, I cannot connect to the web server from my tablet.

noe_vb gravatar imagenoe_vb ( 2013-03-30 05:15:50 -0500 )edit

Do I have to setup a separate network or so? Thank you!

noe_vb gravatar imagenoe_vb ( 2013-03-30 05:19:17 -0500 )edit

Ok your issue is most likely in network, not in ROS. Make sure Android can establish IP connection to your Ubuntu. Btw running roscoreon both ends shouldn't be a problem.

130s gravatar image130s ( 2013-03-30 08:17:46 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-03-29 02:53:35 -0500

Seen: 921 times

Last updated: Mar 29 '13